Home » Server Options » Spatial » SDO_RELATE
SDO_RELATE [message #364152] Sun, 07 December 2008 11:17
Fred
Messages: 34
Registered: August 1999
Member
hi,

I have a problem with the SDO_RELATE spatial operator.
I created one table with a SDO_GEOMETRY column.
I created the SDO_GEOM_METADATA table with the name and dimensions for this column.
I created a spatial index on this column with "create index".
The first filter generated by the SDO_FILTER spatial operator works good, but when I try to use the SDO_RELATE operator, the result is always : "no raw".
Somebody could tell me the reason of this error ? There is some other tables to create ?

Thanks a lot for your help and sorry for my english,

Fred.
Re: SDO_RELATE [message #364153 is a reply to message #364152] Mon, 21 August 2000 09:33 Go to previous message
Lee
Messages: 56
Registered: May 1999
Member
Did you insert a record into INTO USER_SDO_GEOM_METADATA ?
Re: SDO_RELATE [message #364154 is a reply to message #364153] Mon, 21 August 2000 19:33 Go to previous message
Fred
Messages: 34
Registered: August 1999
Member
I inserted in my SDO_GEOM_METADATA a raw with the table name, the column name which contain the SDO_GEOMETRY objects and an array with geometry bound dimensions...
I don't understand why the primary filter works and not the second with the same value for the geometry2 of the operator...
Previous Topic: ORA-29855
Next Topic: Basic Info
Goto Forum:
  


Current Time: Mon Jul 28 04:17:12 CDT 2014

Total time taken to generate the page: 0.15509 seconds