Home » Infrastructure » Unix » Solaris slow disk speed (Solaris 5.10)
Solaris slow disk speed [message #363146] Fri, 05 December 2008 04:12 Go to next message
claytech
Messages: 9
Registered: December 2008
Location: UK
Junior Member
We have currently purchased a SUN SPARC Enterprise T5220 with 2 x 146GB 10K RPM SAS and 2 x 72.8GB 10K RPM SAS disks. I have installed Oracle 10g and created a datbase. The TEMP tablespace and REDO logs and data files all reside on dedicated disks. I have mounted the TEMP, REDO and Datafile filesystems as forcedirectio and set the Oracle setting FILESYSTEMIO_OPTIONS to "SETALL". The speed when writing to disk seems very slow, most of the top waits on the database are for "log file parallel write", "db file parallel write", "direct path write temp",

cann anyone advise on what I might have done wrong.
Re: Solaris slow disk speed [message #363170 is a reply to message #363146] Fri, 05 December 2008 05:12 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
What version of Oracle 10g (specify 4 digit version) are you using ?
Re: Solaris slow disk speed [message #363175 is a reply to message #363170] Fri, 05 December 2008 05:17 Go to previous messageGo to next message
claytech
Messages: 9
Registered: December 2008
Location: UK
Junior Member
Thanks for the reply:

Oracle version 10.2.0.1.0 64bit.
Re: Solaris slow disk speed [message #363176 is a reply to message #363146] Fri, 05 December 2008 05:18 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Did you verify that directio is been used?
It seems that, If some OS patches are missing, directio options set are not effective.
We had a similar issue before.
Please check metalink.
Re: Solaris slow disk speed [message #363178 is a reply to message #363176] Fri, 05 December 2008 05:19 Go to previous messageGo to next message
claytech
Messages: 9
Registered: December 2008
Location: UK
Junior Member
Thanks,

I'll look into this and update
Re: Solaris slow disk speed [message #363183 is a reply to message #363178] Fri, 05 December 2008 05:26 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
As Mahesh indicated, Oracle/Solaris/Direct I/O combination had some issues with 10gR2.

Have you applied patch 5752399 ? If not, you may want to check and see if this applies to you.
Re: Solaris slow disk speed [message #363194 is a reply to message #363183] Fri, 05 December 2008 06:09 Go to previous message
claytech
Messages: 9
Registered: December 2008
Location: UK
Junior Member
Seriously can't thank you enough for yor replies, I thought I'd scanned Metalink but having done so on your advice is appears there are problems with directio and 10.2.0.1, I will be upgrading to 10.2.0.4 next week and re-testing.
Previous Topic: Unable to run binary
Next Topic: How to execute procedure everyday
Goto Forum:
  


Current Time: Tue Dec 06 02:20:54 CST 2016

Total time taken to generate the page: 0.05933 seconds