Home » RDBMS Server » Server Administration » Problem in Loading the data
Problem in Loading the data [message #362695] Wed, 03 December 2008 15:10 Go to next message
kavi123
Messages: 13
Registered: January 2007
Junior Member
Hi All,

Iam trying to load millions of records from a text file in Oracle database using sql*loader.I was doing the same thing since so many months but never faced any issues.Now unexpectedly Iam getting sql loader error

SQL*LOADER-704:Internal Error: u1connect: OCIServerAttach [0]
ORA-12154:TNS:Could not resolve service name.

When Iam trying to connect to database using the Service name it is not giving any problem.

Can anyone help how to resolve this problem.

Thanks in Advance,
Kavitha.
Re: Problem in Loading the data [message #362696 is a reply to message #362695] Wed, 03 December 2008 15:12 Go to previous messageGo to next message
joy_division
Messages: 4640
Registered: February 2005
Location: East Coast USA
Senior Member
SQL> !oerr ora 12154

12154, 00000, "TNS:could not resolve the connect identifier specified"
// *Cause:  A connection to a database or other service was requested using
// a connect identifier, and the connect identifier specified could not
// be resolved into a connect descriptor using one of the naming methods
// configured. For example, if the type of connect identifier used was a
// net service name then the net service name could not be found in a
// naming method repository, or the repository could not be
// located or reached.
// *Action:
//   - If you are using local naming (TNSNAMES.ORA file):
//      - Make sure that "TNSNAMES" is listed as one of the values of the
//        NAMES.DIRECTORY_PATH parameter in the Oracle Net profile
//        (SQLNET.ORA)
//      - Verify that a TNSNAMES.ORA file exists and is in the proper
//        directory and is accessible.
//      - Check that the net service name used as the connect identifier
//        exists in the TNSNAMES.ORA file.
//      - Make sure there are no syntax errors anywhere in the TNSNAMES.ORA
//        file.  Look for unmatched parentheses or stray characters. Errors
//        in a TNSNAMES.ORA file may make it unusable.
//   - If you are using directory naming:
//      - Verify that "LDAP" is listed as one of the values of the
//        NAMES.DIRETORY_PATH parameter in the Oracle Net profile
//        (SQLNET.ORA).
//      - Verify that the LDAP directory server is up and that it is
//        accessible.
//      - Verify that the net service name or database name used as the
//        connect identifier is configured in the directory.
//      - Verify that the default context being used is correct by
//        specifying a fully qualified net service name or a full LDAP DN
//        as the connect identifier
//   - If you are using easy connect naming:
//      - Verify that "EZCONNECT" is listed as one of the values of the
//        NAMES.DIRETORY_PATH parameter in the Oracle Net profile
//        (SQLNET.ORA).
//      - Make sure the host, port and service name specified
//        are correct.
//      - Try enclosing the connect identifier in quote marks.
//
//   See the Oracle Net Services Administrators Guide or the Oracle
//   operating system specific guide for more information on naming.


If it always worked and now doesn't, then something changes, like an environment variable or something.
Re: Problem in Loading the data [message #362698 is a reply to message #362696] Wed, 03 December 2008 15:26 Go to previous message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


Check your default ORACLE_SID from evn. variable

Babu
Previous Topic: Create a copy of an existing oracle database
Next Topic: reclaim unused space for partitioned tables
Goto Forum:
  


Current Time: Mon Dec 05 13:10:26 CST 2016

Total time taken to generate the page: 0.10334 seconds