Home » Developer & Programmer » Forms » RegisterWebUtil not found. (forms 10g)
RegisterWebUtil not found. [message #362677] Wed, 03 December 2008 13:59 Go to next message
arunn
Messages: 52
Registered: September 2008
Location: usa
Member
Hi all,


I am facing the "oracle.forms.webutil.clientinfo.getclientinfo bean not found" error, when i run the demo webutil fmb file.

developer is oracle forms 10g release 2 -- Forms [32 Bit] Version 10.1.2.0.2 (Production)
os is windows xp.
java 6 update 10(build 1.6.0_10-rc-b28)
java(tm) 2runtime environment, standard edition 1.3.1.22-internal
default virtual machine version 1.3.1_15-b01
oracle jinitiator 1.3.1.22

my formsweb.cfg file parameters are like below
# Sample configuration for deploying WebUtil. Note that WebUtil is shipped with
# DS but not AS and is also available for download from OTN.
[webutil]
WebUtilArchive=frmwebutil.jar,jacob.jar
WebUtilLogging=off
WebUtilLoggingDetail=normal
WebUtilErrorMode=Alert
WebUtilDispatchMonitorInterval=5
WebUtilTrustInternal=true
WebUtilMaxTransferSize=16384
baseHTMLjinitiator=webutiljini.htm
baseHTMLjpi=webutiljpi.htm
archive_jini=frmall_jinit.jar
archive=frmall.jar
lookAndFeel=oracle

and also i have added the jacob jar file in classpath.

java console is like below
----------------------------------------------------
load: class oracle.forms.webutil.common.RegisterWebUtil not found.

java.lang.ClassNotFoundException: java.io.IOException: open HTTP connection failed.

at sun.applet.AppletClassLoader.getBytes(Unknown Source)

at sun.applet.AppletClassLoader.access$100(Unknown Source)

at sun.applet.AppletClassLoader$1.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at sun.applet.AppletClassLoader.findClass(Unknown Source)

at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.applet.AppletClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.applet.AppletClassLoader.loadCode(Unknown Source)

at sun.applet.AppletPanel.createApplet(Unknown Source)

at sun.plugin.AppletViewer.createApplet(Unknown Source)

at sun.applet.AppletPanel.runLoader(Unknown Source)

at sun.applet.AppletPanel.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Loading http://153.4.97.96:8889/forms/java/frmall_jinit.jar from JAR cache

proxyHost=null

proxyPort=0

connectMode=HTTP, native.

Forms Applet version is : 10.1.2.0

java.lang.ClassNotFoundException: java.io.IOException: open HTTP connection failed.

at sun.applet.AppletClassLoader.getBytes(Unknown Source)

at sun.applet.AppletClassLoader.access$100(Unknown Source)



sign time result:
D:\DevSuiteHome_2\jdk\bin>sign_webutil.bat D:\DevSuiteHome_2\forms\java\jacob.jar
Generating a self signing certificate for key=webutil2...
keytool error: java.lang.Exception: Key pair not generated, alias <webutil2> already exists
.
There were warnings or errors while generating a self signing certificate. Please review them.
.
Backing up D:\DevSuiteHome_2\forms\java\jacob.jar as D:\DevSuiteHome_2\forms\java\jacob.jar.old...
1 file(s) copied.
Signing D:\DevSuiteHome_2\forms\java\jacob.jar using key=webutil2...
...successfully done.


D:\DevSuiteHome_2\jdk\bin>sign_webutil.bat D:\DevSuiteHome_2\forms\java\frmwebutil.jar
Generating a self signing certificate for key=webutil2...
keytool error: java.lang.Exception: Key pair not generated, alias <webutil2> already exists
.
There were warnings or errors while generating a self signing certificate. Please review them.
.
Backing up D:\DevSuiteHome_2\forms\java\frmwebutil.jar as D:\DevSuiteHome_2\forms\java\frmwebutil.jar.old... 1 file(s) copied.
Signing D:\DevSuiteHome_2\forms\java\frmwebutil.jar using key=webutil2...
...successfully done.

Friends, please guide me on this issue.

arun
Re: RegisterWebUtil not found. [message #362728 is a reply to message #362677] Thu, 04 December 2008 00:27 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Search this forum for 'oracle.forms.webutil'.

Look specifically at http://www.orafaq.com/forum/m/358651/67467/?srch=oracle.forms.webutil#msg_358651 and http://www.orafaq.com/forum/m/362258/67467/?srch=oracle.forms.webutil#msg_362258

David
Re: RegisterWebUtil not found. [message #362889 is a reply to message #362728] Thu, 04 December 2008 07:13 Go to previous messageGo to next message
arunn
Messages: 52
Registered: September 2008
Location: usa
Member
Hi David,

Thanks for your support.

i have checked the both links. its not giving the solution. As per my knowledge, its signing problem. jacob, frmwebutil are not signed properly. The following data is output of sign in command prompt:-

D:\DevSuiteHome_2\jdk\bin>sign_webutil.bat D:\DevSuiteHome_2\forms\java\jacob.jar
Generating a self signing certificate for key=webutil2...
keytool error: java.lang.Exception: Key pair not generated, alias <webutil2> already exists
.
There were warnings or errors while generating a self signing certificate. Please review them.
.
Backing up D:\DevSuiteHome_2\forms\java\jacob.jar as D:\DevSuiteHome_2\forms\java\jacob.jar.old...
1 file(s) copied.
Signing D:\DevSuiteHome_2\forms\java\jacob.jar using key=webutil2...
...successfully done.


D:\DevSuiteHome_2\jdk\bin>sign_webutil.bat D:\DevSuiteHome_2\forms\java\frmwebutil.jar
Generating a self signing certificate for key=webutil2...
keytool error: java.lang.Exception: Key pair not generated, alias <webutil2> already exists
.
There were warnings or errors while generating a self signing certificate. Please review them.
.
Backing up D:\DevSuiteHome_2\forms\java\frmwebutil.jar as D:\DevSuiteHome_2\forms\java\frmwebutil.jar.old... 1 file(s) copied.
Signing D:\DevSuiteHome_2\forms\java\frmwebutil.jar using key=webutil2...
...successfully done.

Please update me on this.

Thanks in advance,

arun
Re: RegisterWebUtil not found. [message #363237 is a reply to message #362889] Fri, 05 December 2008 08:31 Go to previous messageGo to next message
arunn
Messages: 52
Registered: September 2008
Location: usa
Member
i got it
Re: RegisterWebUtil not found. [message #364329 is a reply to message #363237] Mon, 08 December 2008 00:41 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Please share.

David
Re: RegisterWebUtil not found. [message #364652 is a reply to message #362677] Tue, 09 December 2008 07:48 Go to previous messageGo to next message
arunn
Messages: 52
Registered: September 2008
Location: usa
Member
Hi David,

I was hurry on that time. Sorry for late reply.

i have added the frmwebutil.jar,jacob.jar file names in archive_jini parameter of formsweb.cfg file.
old:
# Forms applet archive setting for JInitiator
archive_jini=frmall_jinit.jar
new:
# Forms applet archive setting for JInitiator
archive_jini=frmall_jinit.jar,frmwebutil.jar,jacob.jar

Thanks for your support.

Arun
Re: RegisterWebUtil not found. [message #380894 is a reply to message #362677] Tue, 13 January 2009 18:51 Go to previous message
RAY_HT
Messages: 153
Registered: May 2005
Location: Giza
Senior Member

Please read poster's entry at http://www.orafaq.com/forum/t/138970/67467/
[EDITED by DJM: removed contents that was posted elsewhere as a new thread]

[Updated on: Wed, 14 January 2009 22:47] by Moderator

Report message to a moderator

Previous Topic: Paramlist with Open_Form
Next Topic: how to use the get_record_property in a multi record blcok
Goto Forum:
  


Current Time: Sat Dec 10 05:18:40 CST 2016

Total time taken to generate the page: 0.06953 seconds