Home » Developer & Programmer » Reports & Discoverer » group above report problem? (reports 6i)
group above report problem? [message #362360] Tue, 02 December 2008 00:51 Go to next message
mm_kanish05
Messages: 487
Registered: January 2007
Location: Chennai
Senior Member

Hi
I have done the group above report which work fine, except that the case where a group follow between the page which is repeating (group).

kanish./fa/5380/0/
  • Attachment: main.PNG
    (Size: 27.97KB, Downloaded 275 times)
Re: group above report problem? [message #362377 is a reply to message #362360] Tue, 02 December 2008 01:35 Go to previous messageGo to next message
rajy_salim
Messages: 204
Registered: January 2008
Location: Beirut - Lebanon
Senior Member
Where is your question?

Rajy
Re: group above report problem? [message #362382 is a reply to message #362360] Tue, 02 December 2008 01:56 Go to previous messageGo to next message
mm_kanish05
Messages: 487
Registered: January 2007
Location: Chennai
Senior Member

see, both the pages(9,10) having invoice 590(two times) is repeated. I want it only one time, for that grin may/may not be repeated. (one record can have multiple grinno)

When i convert into a excel and make an cumulative of value im getting two times. So i need one time even page gross between.

kanish
Re: group above report problem? [message #362392 is a reply to message #362360] Tue, 02 December 2008 03:04 Go to previous messageGo to next message
rajy_salim
Messages: 204
Registered: January 2008
Location: Beirut - Lebanon
Senior Member
Quote:
(one record can have multiple grinno)

Then put your record in a higher level group than the grinno, and in the layout, put it in a repeating frame which has to be the repeating frame's parent of the grinno.

Rajy
Re: group above report problem? [message #362405 is a reply to message #362360] Tue, 02 December 2008 03:49 Go to previous messageGo to next message
mm_kanish05
Messages: 487
Registered: January 2007
Location: Chennai
Senior Member

i did the same but my higher group is repeated when it between pages.

./fa/5381/0/
  • Attachment: gp.PNG
    (Size: 8.96KB, Downloaded 249 times)
Re: group above report problem? [message #362428 is a reply to message #362360] Tue, 02 December 2008 04:30 Go to previous messageGo to next message
rajy_salim
Messages: 204
Registered: January 2008
Location: Beirut - Lebanon
Senior Member
I repeat, play with the layout, there is something with your layout which is showing the invoice twice, and that might be its place. Check if the invoice and the grinno are in the same repeating frame, if they are, then split them according to the groups.

P.S Your export to excel work with the layout.

Rajy
Re: group above report problem? [message #362527 is a reply to message #362428] Tue, 02 December 2008 12:15 Go to previous messageGo to next message
Littlefoot
Messages: 20888
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I probably didn't understand the problem (image is probably clear to you, but not to me).

However: shouldn't INV_NO be in its own group above the rest of the columns (speaking in terms of Data Model Layout)? If that's the case, it will be repeated only once (and you can choose whether to make it as a "group left" or "group above" layout).
Re: group above report problem? [message #362535 is a reply to message #362360] Tue, 02 December 2008 21:52 Go to previous messageGo to next message
mm_kanish05
Messages: 487
Registered: January 2007
Location: Chennai
Senior Member

hi
sorry it is group left report,see the picture of page 9 at vert bottom


page 9

   590    11-jul-08   7887  81060288   82410070
                                       82410069
                                       82410068




page 10

   590    11-jul-08   7887  81060288   82410067
                                       82410066
                                       82410063

                                       82410061


but i required even in between page should come like below

page 9

   590    11-jul-08   7887  81060288   82410070
                                       82410069
                                       82410068



page10                                 82410067
                                       82410066
                                       82410063
                                       82410061




i thought you can understand.




./fa/5386/0/


kanish
  • Attachment: gp1.PNG
    (Size: 23.92KB, Downloaded 216 times)
Re: group above report problem? [message #362577 is a reply to message #362360] Wed, 03 December 2008 01:33 Go to previous messageGo to next message
rajy_salim
Messages: 204
Registered: January 2008
Location: Beirut - Lebanon
Senior Member
I think I could understand you now.
It's the "Print Object On" property of your fields. It is set to "All Pages". Change it to "First Page".

Note that this "page" is a logical page and not a physical page.

Hope this helps you.

Rajy
Re: group above report problem? [message #362579 is a reply to message #362535] Wed, 03 December 2008 01:37 Go to previous messageGo to next message
Littlefoot
Messages: 20888
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I *think* I know what the problem is: select all fields you'd like to display only once and modify their "Print Object On" property to "First Page".

[EDIT]

LOL! Obviously, Rajy got the same idea. It took some time to create a dummy report and test it; meanwhile, Rajy was writing his message. It appears that this might be solution to the problem.

[Updated on: Wed, 03 December 2008 01:39]

Report message to a moderator

Re: group above report problem? [message #362582 is a reply to message #362360] Wed, 03 December 2008 01:49 Go to previous messageGo to next message
rajy_salim
Messages: 204
Registered: January 2008
Location: Beirut - Lebanon
Senior Member
LOL! It's part of any developer's work: "Getting Ideas".
Isn't it what we call "Experience in doing something"?? Laughing

Rajy
Re: group above report problem? [message #362605 is a reply to message #362360] Wed, 03 December 2008 03:44 Go to previous messageGo to next message
mm_kanish05
Messages: 487
Registered: January 2007
Location: Chennai
Senior Member

Thanks
Re: group above report problem? [message #362609 is a reply to message #362605] Wed, 03 December 2008 03:56 Go to previous message
rajy_salim
Messages: 204
Registered: January 2008
Location: Beirut - Lebanon
Senior Member
mm_kanish05 wrote on Wed, 03 December 2008 03:44
Thanks

Thanks for what? For providing the good solution or a bad one? You didn't share the result.
Did you try it? Have your problem been solved? Was that the good solution?

Rajy
Previous Topic: Call report From Menu
Next Topic: No response from web server
Goto Forum:
  


Current Time: Sat Dec 03 05:42:18 CST 2016

Total time taken to generate the page: 0.23323 seconds