Home » RDBMS Server » Server Administration » Index problem after import using imp (Oracle Database 10g Express Edition Release 10.2.0.1.0 on Windows XP Professional)
Index problem after import using imp [message #361686] Thu, 27 November 2008 08:15 Go to next message
balamuruganm
Messages: 2
Registered: November 2008
Junior Member
I created a database in Oracle Database 10g Express Edition Release 10.2.0.1.0 in one machine. I created users, tables, views etc through script. I inserted data.

Now I wanted the data to be moved to another machine. I installed Oracle Database 10g Express Edition Release 10.2.0.1.0 there. I took a dmp from the first machine using the exp command. The copied the dump to the new machine and imported it using the imp command. Everything went fine.

I accessed the database using my web application in the new machine. For most part it was fine. But for some queries it is taking a long time to execute. (more than 10 minutes)

After using explain plan and trace I found out that the query running in machine 1 picks up different index than when the query is running in machine 2.

Why is there a discrepancy? Is that problem with Oracle Database 10g Express Edition Release 10.2.0.1.0?

Please help.

Thanks
Re: Index problem after import using imp [message #361697 is a reply to message #361686] Thu, 27 November 2008 10:31 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Prove it. Post it. Describe it.
Just explaining what you did helps us very little.
Check the statistics (atleast the last_analyzed from user_tables/user_indexes).
Recollect the stats and try again.
Depending on how exactly you did export/import, the stats may get copied /changed.

[Updated on: Thu, 27 November 2008 10:33]

Report message to a moderator

Re: Index problem after import using imp [message #361848 is a reply to message #361697] Fri, 28 November 2008 04:43 Go to previous message
balamuruganm
Messages: 2
Registered: November 2008
Junior Member
Thanks a lot!

"Recollect the stats and try again." - It did work after doing the step mentioned by you

Previous Topic: ORA-00604: error occurred at recursive SQL level 1
Next Topic: Release Space
Goto Forum:
  


Current Time: Sun Dec 04 02:19:05 CST 2016

Total time taken to generate the page: 0.07831 seconds