Home » Developer & Programmer » Forms » Exception in Webutil (Forms 10g, XP)
Exception in Webutil [message #360337] Thu, 20 November 2008 08:39 Go to next message
svsig
Messages: 7
Registered: November 2008
Location: Norway
Junior Member
I am trying to install and configure Webutil to work with my converted Forms 10g modules. In one form I am trying to open a file and read the contents. From Webutil I get the exception 302000 - non-oracle-exception.

My form calls CLIENT_TEXT_IO.FOPEN in the webutil library. FOPEN calls WebUtil_Core.setProperty, and setProperty then executes the following call:

bean := find_item(getHandlerBean(packageID));

It looks like an error occurs in getHandlerPackage, and it looks like it is caused by the variable m_registeredpackages, which is supposed to "hold the list of all the beans that have made themselves known to the form". It seems that m_registeredpackages has not been initiated.

It could of course have something to do with my setup. I have tried to follow the description in Oracle's WebUtil User's guide, Release 1.0.6. I have done the following:

- Downloaded webutil_106.zip and unzipped
- Downloaded jacob_18.zip and unzipped
- Created the user webutil in my test database
- Granted execute on dbms_lob, utl_encode and utl_raw to webutil
- Run the script create_webutil_db.sql
- Created public synonym for webutil_db
- Granted execute on webutil_db to public
- Copied files frmwebutil.jar and jacob.jar to ORACLE_HOME\forms\java
- Signed frmwebutil.jar and jacob.jar
- Copied jacob.dll to ORACLE_HOME\forms\webutil\webutil
- Set the following parameters in formsweb.cfg:

    webuUtilArchive=frmwebutil.jar,jacob.jar
    baseHTML=webutilbase.htm
    baseHTMLjinitiator=webutiljini.htm
    baseHTMLjpi=webutiljpi.htm

- Checked the following parameters in default.env:

    FORMS_PATH contains a path to webutil.pll
    WEBUTIL_CONFIG contains a path to webutil.cfg
    CLASSPATH contains a path to frmwebutil.jar and rt.jar


Am I missing something here? Or has anyone else experienced this error and found a solution?

Regards,
Sveinung
Re: Exception in Webutil [message #360762 is a reply to message #360337] Mon, 24 November 2008 00:03 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Can you run the 'test' form for 'webutil'?

David
Re: Exception in Webutil [message #360967 is a reply to message #360762] Mon, 24 November 2008 08:24 Go to previous messageGo to next message
svsig
Messages: 7
Registered: November 2008
Location: Norway
Junior Member
There was no form module in the webutil zip file. Where can I find this form?

Regards,
Sveinung
Re: Exception in Webutil [message #361074 is a reply to message #360967] Tue, 25 November 2008 00:22 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
There should be a 'WU_TEST.fmb' (and a 'ReadMe.html')in 'webutil_demo.zip' on the Oracle website.

David
Re: Exception in Webutil [message #361207 is a reply to message #360337] Tue, 25 November 2008 06:37 Go to previous message
svsig
Messages: 7
Registered: November 2008
Location: Norway
Junior Member
Thanks for the tip! I downloaded the form and it seems to work. Then at least I know that my installation seems to be OK. Now I will have to look closer at my form, I can see there are several details here that I need to find out more about. Thank you very much for now. I will most certainly be back with further questions later.

Sveinung
Previous Topic: Using SAVEPOINT in Forms
Next Topic: Problem when installing Forms10g R2
Goto Forum:
  


Current Time: Sun Dec 04 08:28:14 CST 2016

Total time taken to generate the page: 0.20399 seconds