Home » RDBMS Server » Server Administration » Oracle 9i (Password Issue of sys user)
Oracle 9i [message #360232] Thu, 20 November 2008 02:22 Go to next message
manoj12
Messages: 185
Registered: March 2008
Location: India
Senior Member
Dear Sir

After installing Oracle 9i into my server at the time of installation in the Password Management It has asked me to change the password of sys password as well as sytem password.I changed the password from sys to "sach123" and changed the system password from manager to "sach1234" in the password management.After changing the password I rebooted my server machine.After rebooting I tried to connect the sys user through
username as "sys as sysdba" and Password as "sach123".The sys user gets connected through the password as "sach123".But Now the issue is when I am connecting sys user with username as
"sys as sysdba" and password as "as sysdba" Still I am able to get connected to the sys user.I dont want sys user to connect through "as sysdba" password.I wanted sys user to connect through "sach123" so that my sys user password is secured with me.

Please help me How I should connect sys user through "sach123" and not through "as sysdba" password.I even tried to change the password of sytem user to "sach".The sytem default password is "manager".After changing the system password to "sach" The system user is succesfully getting connected through "sach" user whereas for system user manager is not getting connected because the password I have changed for system user as well.

Appreciate your help on the above issue?

Regards

[Updated on: Thu, 20 November 2008 06:03]

Report message to a moderator

Re: Oracle 9i [message #360237 is a reply to message #360232] Thu, 20 November 2008 02:31 Go to previous messageGo to next message
ThomasG
Messages: 3189
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
If you are logged in on the server with the Oracle operating system user, or any other user in the "DBA" operating system group then you can always connect "as sysdba" without a password, so the password you enter there doesn't matter.

The password is only checked if the user is not in the DBA group or is connecting remotely to oracle.
Re: Oracle 9i [message #360305 is a reply to message #360232] Thu, 20 November 2008 06:15 Go to previous messageGo to next message
manoj12
Messages: 185
Registered: March 2008
Location: India
Senior Member
Dear Sir

I wanted to make the sys password a secured password.I wanted user should get an error while trying to connect through "as sysdba" password .How I should do it.So that password is so secured with me

How I should do it?

Regards
Re: Oracle 9i [message #360322 is a reply to message #360305] Thu, 20 November 2008 07:15 Go to previous messageGo to next message
ThomasG
Messages: 3189
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
There is no way to lock out an operating system user that is in the DBA group from logging into the database "as sysdba".

Just the same way as there is no way to prevent the root user from su'ing into any other user accounts without a password.

So just don't put the users in the DBA group. Only put the oracle OS user in the DBA group, and don't give anybody the operating system password for that account.

[Updated on: Thu, 20 November 2008 07:16]

Report message to a moderator

Re: Oracle 9i [message #360342 is a reply to message #360322] Thu, 20 November 2008 09:22 Go to previous messageGo to next message
tahpush
Messages: 961
Registered: August 2006
Location: Stockholm/Sweden
Senior Member

If you are running your Oracle DB on Windows, read the documentation about parameter SQLNET.AUTHENTICATION_SERVICES which resides in sqlnet.ora

What you could do then is to prevent the possibilty to connect /as sysdba, without supplying a password.
Re: Oracle 9i [message #360343 is a reply to message #360322] Thu, 20 November 2008 09:22 Go to previous message
Michel Cadot
Messages: 64151
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Actually you can do it if you set SQLNET.AUTHENTICATION_SERVICES = (NONE) in sqlnet.ora

Regards
Michel
Previous Topic: SYSTEM Tablespace "Full"
Next Topic: "Snapshot is too old" problem
Goto Forum:
  


Current Time: Fri Dec 09 13:38:07 CST 2016

Total time taken to generate the page: 0.20462 seconds