Home » RDBMS Server » Server Utilities » Import error (oracle 10.2.0,linux)
Import error [message #358428] Tue, 11 November 2008 04:50 Go to next message
yjshanmukh
Messages: 4
Registered: January 2008
Junior Member
Hi,
While importing the dump from production server to the local server,After all the tables are imported quite well but in the end I got the following error, no procedures or packages were imported.Can somebody suggest a solution.
At production it is oracle 10.2.0 on redhat-5 64-bit
At local test server it is oracle 10.1.0 on fedora core-3


. . importing table "RESELLER_DOWNLOAD_DETAILS" 36 rows imported
. . importing table "SUPPLIER_DOWNLOAD_DETAILS" 11 rows imported
IMP-00017: following statement failed with ORACLE error 2248:
"ALTER SESSION SET PLSQL_OPTIMIZE_LEVEL = 1 NLS_LENGTH_SEMANTICS = 'BYTE' PL"
"SQL_CODE_TYPE = 'INTERPRETED' PLSQL_DEBUG = FALSE PLSQL_WARNINGS = 'DISABLE"
":ALL'PLSQL_CCFLAGS = ''"
IMP-00003: ORACLE error 2248 encountered
ORA-02248: invalid option for ALTER SESSION
IMP-00000: Import terminated unsuccessfully

[Updated on: Tue, 11 November 2008 05:21]

Report message to a moderator

Re: Import error [message #358437 is a reply to message #358428] Tue, 11 November 2008 05:57 Go to previous messageGo to next message
Michel Cadot
Messages: 64151
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Did you export with 10.1 exp binary?
If not, retry with it. You must export with the lowest version.

Regards
Michel

[Updated on: Tue, 11 November 2008 05:58]

Report message to a moderator

Re: Import error [message #358444 is a reply to message #358428] Tue, 11 November 2008 06:35 Go to previous messageGo to next message
yjshanmukh
Messages: 4
Registered: January 2008
Junior Member

I exported from 10.2.0 on redhat-5 and import to 10.1.0 on fedora. I dint use any binary parameter ???

exp system/password file=scom.dmp log=scom.log owner=scom

imp system/password file=scom.dmp log=impscom.log fromuser=scom touser=scomtest buffer=6000000

Thanks
Re: Import error [message #358449 is a reply to message #358444] Tue, 11 November 2008 07:12 Go to previous message
Littlefoot
Messages: 20901
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
"Binary" in Michel's post refers to EXP and IMP executable files.

On MS Windows, these would be EXP.EXE and IMP.EXE (I wouldn't know extensions, if any, on your operating system. Might be the same, though).

During EXPORT, you have to invoke executable version which belongs to 10.1.0 Oracle database. It can be done by naming the full path to the file, such as
> c:\oracle\10.1.0\bin\exp un/pw file=...

As rule of thumb: do the export using the LOWER database version's EXP utility, and do the import using the TARGET database version's IMP utility.
Previous Topic: how to open.dmp file
Next Topic: export from 9i import to 10g
Goto Forum:
  


Current Time: Fri Dec 09 13:33:16 CST 2016

Total time taken to generate the page: 0.29071 seconds