Home » RDBMS Server » Enterprise Manager » Data not shown in EM (RedHat 4 EL)
Data not shown in EM [message #358277] Mon, 10 November 2008 08:26 Go to next message
meo_beo
Messages: 12
Registered: September 2008
Junior Member
Hi, there's a problem I haven't been able to solve and I'm asking for your help. When I inserted data to the tables of my database by sqlplus, the data are not shown in EM. Of course, I can still view the data in sqlplus, but not EM. The strange thing is that, the first table I inserted data in I can view its data alright by EM. After inserting data to the first table, I turned the DB off and inserted the data of the subsequent tables a few days later but the data of those table cannot be shown by EM. I searched those table and tried to "View Data" but no rows were returned. Can anyone tell me what the problem is? Thanks a lot.

[Updated on: Mon, 10 November 2008 08:28]

Report message to a moderator

Re: Data not shown in EM [message #358342 is a reply to message #358277] Mon, 10 November 2008 15:50 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Are you committing after you insert ?
Re: Data not shown in EM [message #358410 is a reply to message #358342] Tue, 11 November 2008 02:56 Go to previous messageGo to next message
meo_beo
Messages: 12
Registered: September 2008
Junior Member
No, I don't remember doing that. If I want to commit now (after inserting the data), what do I have to do?
Re: Data not shown in EM [message #358413 is a reply to message #358410] Tue, 11 November 2008 03:03 Go to previous messageGo to next message
Michel Cadot
Messages: 64133
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
commit;
from the session that inserted the data.

Regards
Michel

[Updated on: Tue, 11 November 2008 03:04]

Report message to a moderator

Re: Data not shown in EM [message #358433 is a reply to message #358413] Tue, 11 November 2008 05:20 Go to previous message
meo_beo
Messages: 12
Registered: September 2008
Junior Member
Sorry, but how can I come back to the session in which I inserted the data so as to commit the changes? By the way, when I log in the DB, there is a message like this:

Enterprise Manager is unable to proceed. The most likely cause of this is that database session information could not be retrieved or that EM was unable to process a user-invoked bookmark. Press OK to continue.

Can you please tell me what it means? Thank you.
Previous Topic: SSL for Enterprise Manager
Next Topic: sequence to change em users passwords
Goto Forum:
  


Current Time: Thu Dec 08 04:03:27 CST 2016

Total time taken to generate the page: 0.05889 seconds