Home » SQL & PL/SQL » SQL & PL/SQL » htp.formOpen(...) problem
htp.formOpen(...) problem [message #357294] Tue, 04 November 2008 13:46
mhakimjavadi
Messages: 37
Registered: July 2008
Member
Hello all,

I'm having a problem with htp.formOpen(...) in the following code:


CREATE OR REPLACE PACKAGE BODY insert_into AS
.
.
.
PROCEDURE insert_country(name IN VARCHAR2 DEFAULT NULL) IS
BEGIN
header;
htp.print(name);
footer;
END insert_country;


PROCEDURE country IS
BEGIN
header;
htp.header(1,'Insert data into the "Country" table');
htp.formOpen('insert_into.insert_country');
htp.print('Enter a Country');
htp.formText('country_data');
htp.formSubmit(cvalue=>'Execute');
htp.formClose;
htp.br;
footer;
END country;
.
.
.
END insert_into;

I use this code inside a package named 'insert_into'. I load the procedure 'insert_into.country' with my browser and I see the form. By pressing the "Execute" button, it should submit the form and call the "insert_into.insert_country" procedure just to show nothing (a test).
BUT, whenever I press the "Execute" button instead of seeing the generated page from 'insert_into.insert_country' I get the infamous 404 error - page not found. Once I press 'refresh' in my browser on the same page I get 404 I suddenly see the page generated by insert_into.insert_country.

any ideas why I get 404 while the procedure exists and is viewable in the browser?

Thanks
Previous Topic: How To Alter Current Schedule Job via DBMS_SCHEDULER
Next Topic: How to run .sql script from pl/sql
Goto Forum:
  


Current Time: Fri Dec 09 23:22:07 CST 2016

Total time taken to generate the page: 0.15280 seconds