Home » RDBMS Server » Enterprise Manager » Question about repository creation
icon5.gif  Question about repository creation [message #356047] Wed, 29 October 2008 03:23 Go to next message
prepek2000
Messages: 5
Registered: October 2008
Junior Member
Hi to all!
Im not sure does command emca -config dbcontrol db creates repository? I have done cloning of db manually and I've added it successfully to db console, but im not sure does this command creates repository also for this new database?

Regards!
Re: Question about repository creation [message #356164 is a reply to message #356047] Wed, 29 October 2008 15:36 Go to previous messageGo to next message
babuknb
Messages: 1703
Registered: December 2005
Location: NJ
Senior Member


Yes it's should create in new database also.

But after creating database (clone database). Please try to re-create your repository using

emca -config dbcontrol db -repos recreate


Babu
Re: Question about repository creation [message #356275 is a reply to message #356047] Thu, 30 October 2008 02:36 Go to previous messageGo to next message
prepek2000
Messages: 5
Registered: October 2008
Junior Member
Thank for reply!

SO just to be sure, i have this scenario now:

I have done cloning of database, but with 2 different names, so mine original database and other two are clones on one server....
So now when i do emca -config dbcontrol db -repos recreate for original db test it goes ok, but for other two db's i receive errors for creating repository, so only command emca -config dbcontrol db goes ok.... Where i make mistake?

Re: Question about repository creation [message #356436 is a reply to message #356275] Thu, 30 October 2008 13:18 Go to previous messageGo to next message
babuknb
Messages: 1703
Registered: December 2005
Location: NJ
Senior Member

Hello,

1. What's your database version?
2. OS Version?
3. Please post your error message.

Thanks & Regards
Babu

[Updated on: Thu, 30 October 2008 13:20]

Report message to a moderator

Re: Question about repository creation [message #356610 is a reply to message #356047] Fri, 31 October 2008 08:45 Go to previous messageGo to next message
prepek2000
Messages: 5
Registered: October 2008
Junior Member
Version of db is 10.2.0 and OS is Red Hat Enterprise Linux AS release 4 (Nahant Update 5)


This is begining of output eror from /cfgtoolllogs/emca/name_of_db

Check if repos user already exists.

old 6: WHERE username=UPPER('&EM_REPOS_USER');
new 6: WHERE username=UPPER('SYSMAN');
old 8: IF ( '&EM_CHECK_TYPE' = 'EXISTS') THEN
new 8: IF ( 'NOT_EXISTS' = 'EXISTS') THEN
old 11: raise_application_error(-20000, '&EM_REPOS_USER does not exists..');
new 11: raise_application_error(-20000, 'SYSMAN does not exists..');
old 14: ELSIF ( '&EM_CHECK_TYPE' = 'NOT_EXISTS' ) THEN
new 14: ELSIF ( 'NOT_EXISTS' = 'NOT_EXISTS' ) THEN
old 17: raise_application_error(-20001, '&EM_REPOS_USER already exists..');
new 17: raise_application_error(-20001, 'SYSMAN already exists..');
old 21: raise_application_error(-20002, 'Invalid Check type &EM_CHECK_TYPE');
new 21: raise_application_error(-20002, 'Invalid Check type NOT_EXISTS');
.
.
.
.
.
.
.

Set repository version

BEGIN dbms_registry.loaded('EM'); END;

*
ERROR at line 1:
ORA-25153: Temporary Tablespace is Empty
ORA-06512: at "SYS.DBMS_STATS", line 13210
ORA-06512: at "SYS.DBMS_STATS", line 13517
ORA-06512: at "SYS.DBMS_STATS", line 15859
ORA-06512: at "SYS.DBMS_STATS", line 15901
ORA-06512: at line 1
ORA-06512: at "SYS.DBMS_REGISTRY", line 560
ORA-06512: at "SYS.DBMS_REGISTRY", line 612
ORA-06512: at line 1

and this is end line....
In the middle of output are successfully commited procedures and etc...
Re: Question about repository creation [message #356660 is a reply to message #356610] Fri, 31 October 2008 15:43 Go to previous messageGo to next message
babuknb
Messages: 1703
Registered: December 2005
Location: NJ
Senior Member

http://www.orafaq.com/forum/t/88153/0/
Please read & follow Posting Guideline as stated in URL above

You have TEMP tablespace in your database???

Babu
Re: Question about repository creation [message #356664 is a reply to message #356660] Fri, 31 October 2008 15:55 Go to previous messageGo to next message
prepek2000
Messages: 5
Registered: October 2008
Junior Member
No i dont have temp tablespace, so i need to create it... That will solve my problem ?

Thanks....
Re: Question about repository creation [message #356665 is a reply to message #356664] Fri, 31 October 2008 15:59 Go to previous message
babuknb
Messages: 1703
Registered: December 2005
Location: NJ
Senior Member

Please create TEMP tablespace & Try to re-create repository

Using

emca -config dbcontrol db -repos recreate


Babu

[Updated on: Fri, 31 October 2008 16:00]

Report message to a moderator

Previous Topic: My enterprise manager
Next Topic: DBConsole causing database slowness- EMD_NOTIFICATION.QUEUE_READY causes SQL*Net break/reset waits
Goto Forum:
  


Current Time: Fri Apr 18 08:37:32 CDT 2014

Total time taken to generate the page: 0.14852 seconds