Home » Server Options » Replication » Error during addtion of mastersite (Oracle 9i, Windows)
Error during addtion of mastersite [message #354408] Sat, 18 October 2008 09:30 Go to next message
sanei05
Messages: 103
Registered: September 2008
Senior Member
hi,
i get below error when i tried to add the master site to the master definition site.

SQL> BEGIN
2 DBMS_REPCAT.ADD_MASTER_DATABASE(
3 gname => 'TEST',
4 master=> 'testdb2',
5 use_existing_objects => FALSE,
6 copy_rows => FALSE,
7 propagation_mode => 'synchronous');
8 END;
9 /
BEGIN
*
ERROR at line 1:
ORA-00001: unique constraint (SYSTEM.REPCAT$_REPCAT_PRIMARY) violat
ORA-06512: at "SYS.DBMS_REPCAT_UTL", line 2632
ORA-06512: at "SYS.DBMS_REPCAT_RPC", line 306
ORA-06512: at "SYS.DBMS_REPCAT_MAS", line 2327
ORA-06512: at "SYS.DBMS_REPCAT", line 146
ORA-06512: at line 2


Can anyone help me where am i going wrong
Re: Error during addtion of mastersite [message #354670 is a reply to message #354408] Mon, 20 October 2008 13:27 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


select gname from dba_repgroup


Please post output of the above query

Babu
Re: Error during addtion of mastersite [message #355494 is a reply to message #354670] Fri, 24 October 2008 08:25 Go to previous messageGo to next message
sanei05
Messages: 103
Registered: September 2008
Senior Member
Thanks for your reply..
I have setted up the replication..
I was waiting for the reply and finally i got the solution from my end itself..
Re: Error during addtion of mastersite [message #355749 is a reply to message #354408] Mon, 27 October 2008 06:06 Go to previous messageGo to next message
foster06
Messages: 11
Registered: September 2008
Location: NICE
Junior Member
Hello,

I have a similar pb.
Could you tell us your solution.
Thanks
Re: Error during addtion of mastersite [message #356055 is a reply to message #355749] Wed, 29 October 2008 04:11 Go to previous messageGo to next message
sanei05
Messages: 103
Registered: September 2008
Senior Member
I was running this script on both database. Then I ran this script only in the master def site and gave the propagation mode as "ASYNCHRONOUS". Also I rectified the primary constraint from one of the table i had on both database. i guess you have to check with your tables on both databases.
Re: Error during addtion of mastersite [message #356063 is a reply to message #356055] Wed, 29 October 2008 04:49 Go to previous message
foster06
Messages: 11
Registered: September 2008
Location: NICE
Junior Member
Thanks,
But I think it's not the same problem.
You can see how I resolve it inthe message #355743
Previous Topic: Materialized view does not refresh
Next Topic: How to monitor complete refresh
Goto Forum:
  


Current Time: Fri Dec 02 20:40:54 CST 2016

Total time taken to generate the page: 0.13049 seconds