Home » Developer & Programmer » JDeveloper, Java & XML » xdb.jar JDK problem (urgent) (Oracle 11G)
xdb.jar JDK problem (urgent) [message #354379] Sat, 18 October 2008 05:10 Go to next message
n_bekrar
Messages: 2
Registered: October 2008
Junior Member
Storing information in XmlDB Functionality, uses xdb.jar (Provided by Oracle). In database the xml is stored in the column of type "XMLType"

Oracle provides a java library (xdb.jar) to convert the stored xml to java object(XMLType object). This library has dependency on the xmlparserv2.jar this is also provided by oracle.

The xdb.jar of oracle11g uses newer version of java(1.5) so these classes cannot be loaded at runtime because the JVM of our appserver is 1.4 compliant.

Could you please show me a direction to follow to find a solution the that urgent problem.

NB: we tried to use the xdb.jar provided with oracle 10G that is compatible with JDK 1.4 but faced anther exception (due to the incompatibility of the jar with 11G)

Exceptions enclosed.

  • Attachment: exception.txt
    (Size: 30.77KB, Downloaded 498 times)
Re: xdb.jar JDK problem (urgent) [message #354387 is a reply to message #354379] Sat, 18 October 2008 06:04 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
Can't you use a Java 5 JVM?

Oh, and if it's urgent, you should call Oracle Support, not ask in a forum.

[Updated on: Sat, 18 October 2008 06:05]

Report message to a moderator

Re: xdb.jar JDK problem (urgent) [message #354445 is a reply to message #354387] Sun, 19 October 2008 02:37 Go to previous messageGo to next message
n_bekrar
Messages: 2
Registered: October 2008
Junior Member
I can't, because my APP server Was5.1 works on JDK 1.4 and and my software can work only on Was5.1 Sad

For Oracle Support i did, no answer for the moment. i posted in the forum in case where someone faced that probleme before.

Thanks for your help Smile

[Updated on: Sun, 19 October 2008 02:38]

Report message to a moderator

Re: xdb.jar JDK problem (urgent) [message #354595 is a reply to message #354379] Mon, 20 October 2008 08:56 Go to previous messageGo to next message
lcotonea
Messages: 2
Registered: October 2008
Junior Member
You can eventually use this tool: retroweaver (<a href="http://retroweaver.sourceforge.net/" target="_blank"></a>). It permits to downgrade your bytecode to insure a Java 1.4 compatibility. So you can downgrade the bytecode of xsd.jar and xmlparserv2.jar.

But I don't know if this manipulation is authorised by the Oracle license that cover xsd.jar and xmlparserv2.jar... Any idea?

[Updated on: Mon, 20 October 2008 08:56]

Report message to a moderator

Re: xdb.jar JDK problem (urgent) [message #354607 is a reply to message #354445] Mon, 20 October 2008 09:56 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
Then I'd say your application should not be certified to run on an 11g Database!
Re: xdb.jar JDK problem (urgent) [message #354621 is a reply to message #354379] Mon, 20 October 2008 10:37 Go to previous messageGo to next message
lcotonea
Messages: 2
Registered: October 2008
Junior Member
Yes. This is the risk.

Re: xdb.jar JDK problem (urgent) [message #354635 is a reply to message #354621] Mon, 20 October 2008 11:08 Go to previous message
Frank
Messages: 7880
Registered: March 2000
Senior Member
I don't mean your hack. I was referring to the original post.
Seems to me that he upgraded his database to a non-supported level. (Non-supported for his application)
Previous Topic: Convert 10G forms&reports to jdeveloper
Next Topic: ORA-01000: maximum open cursors exceeded
Goto Forum:
  


Current Time: Wed Dec 07 16:14:51 CST 2016

Total time taken to generate the page: 0.11343 seconds