Home » RDBMS Server » Server Administration » NLS Problem in 10g R2
NLS Problem in 10g R2 [message #351659] Thu, 02 October 2008 03:29 Go to next message
dbcop
Messages: 37
Registered: September 2006
Location: india
Member
Hi Gurus,


I am facing a situation where I am running a particular job throws me a very known error.
The job succeeds when I run it as an oracle user but fails when I try to run it as another user .

The error it returns is as follows

ORA-12705:Cannot access NLS data files or invalid environment specified.

Env:AIX DB:Oracle10g r2

I did the following things.

I have set the permission for nls,data etc under $ORACLE_HOME as 755 with all .nlb files as 644.
ORA_NLS10 env variable is correctly set to $ORACLE_HOME/nls/data.

I have even tried to unset the ORA_NLS10 env to make use of the default one but still failed with the same error.
Apparently it looks to be a permission issue but I have set them s my per knowledge.I have even compared the env settings for both the oracle users and the other one.

ORA_NLS10=/oracle/MPW/102_64/nls/data
NLS_LANG=AMERICAN_AMERICA.WE8DEC

Any quick help help is highly appreciated. Please let me know if I am missing anything.


Thanks and Regards

Re: NLS Problem in 10g R2 [message #351660 is a reply to message #351659] Thu, 02 October 2008 03:35 Go to previous messageGo to next message
Michel Cadot
Messages: 64152
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
ORA-12705: Cannot access NLS data files or invalid environment specified
 *Cause: Either an attempt was made to issue an ALTER SESSION command
         with an invalid NLS parameter or value; or the environment
         variable(s) NLS_LANG, ORA_NLSxx, or ORACLE_HOME was incorrectly
         specified, therefore the NLS data files cannot be located.
 *Action: Check the syntax of the ALTER SESSION command and the NLS
          parameter, correct the syntax and retry the statement, or
          specify the correct directory path/values in the environment
          variables.

Regards
Michel
Re: NLS Problem in 10g R2 [message #351667 is a reply to message #351660] Thu, 02 October 2008 04:33 Go to previous messageGo to next message
dbcop
Messages: 37
Registered: September 2006
Location: india
Member
Hi Michel,Thanks for the update


Before posting this problem I had already searched it in metalink/google etc

I already checked for the update you have provided these things have already been taken care of.

The job that I am running doesnot make use of any alter session.
Moreover if you see my problem description env varibales have already been set correctly including oracle home.

Please note that when I am running this job as oracle user it runs without any error.

Any other clues?


Thanks
Re: NLS Problem in 10g R2 [message #351671 is a reply to message #351667] Thu, 02 October 2008 04:41 Go to previous messageGo to next message
Michel Cadot
Messages: 64152
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Quote:
Moreover if you see my problem description env varibales have already been set correctly including oracle home

Yes but this is the only thing your mentioned and you didn't mention that you don't use ALTER SESSION, you didn't mention what kind of job it is, you didn't mention if it is the same client (not username) that executes the tests...
Also you didn't mention if you have any database trigger.
So check NLS all these.

Regards
Michel
Re: NLS Problem in 10g R2 [message #351673 is a reply to message #351671] Thu, 02 October 2008 04:54 Go to previous message
dbcop
Messages: 37
Registered: September 2006
Location: india
Member
There are no database triggers.

I didn't understand what the following statement meant

"you didn't mention if it is the same client (not username) that executes the tests..."

I am running this job sitting on the server itself using putty to connect to the server

As I said earlier when I login to the system using oracle user and run this job from the command prompt it runs without any error.But when I login to the sytem using another user id belonging to DBA group it fails and the error reproduces.


Thanks



The job contains a couple of DML staments for some table updation.


It is being called from the command prompt itself.


[Updated on: Thu, 02 October 2008 04:56]

Report message to a moderator

Previous Topic: What is the Default password for the SYS user in oracle 10g
Next Topic: job of type EXECUTABLE failed with exit code: Device busy in dbms_scheduler job
Goto Forum:
  


Current Time: Sat Dec 10 09:24:36 CST 2016

Total time taken to generate the page: 0.20559 seconds