Home » Server Options » Data Guard » Error: ORA-16642: db_unique_name mismatch
Error: ORA-16642: db_unique_name mismatch [message #349842] Tue, 23 September 2008 04:46 Go to next message
rolex.mp
Messages: 161
Registered: February 2007
Senior Member
I am using Oracle 10.2.0.3 Enterprise Edition on RHEL.

I am configuring Data Guard for a RAC two node database. I am trying to learn configuring Data Guard Broker for a RAC database.

The database is a RAC database (orcl) with instances orcl1 and orcl2 configured on nodes rac1 and rac2.

Now I have created a physical standby database with db unique name orcl3 on node rac2 and the db name is orcl as needed for a standby. This is not a RAC database.

I am trying to configure data guard broker for the same. I am running the following commands from rac2 node with the environment pointing to the database orcl3.
oracle@rac2:/u01/app/oracle/product/10.2.0/db/bin:$ dgmgrl
DGMGRL for Linux: Version 10.2.0.3.0 - 64bit Production

Copyright (c) 2000, 2005, Oracle. All rights reserved.

Welcome to DGMGRL, type "help" for information.
DGMGRL> connect sys
Password:
Connected.
DGMGRL> create configuration DRTest AS primary database is orcl CONNECT IDENTIFIER IS orcl;
Error: ORA-16642: db_unique_name mismatch


The entry in tnsnames.ora is as follows

orcl =
  (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = vrac1)(PORT = 1521))
    (ADDRESS = (PROTOCOL = TCP)(HOST = vrac2)(PORT = 1521))
    (LOAD_BALANCE = yes)
    (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = ORCL.ORGTS.LOCAL)
    )
  )


Please help me resolve this issue.
Re: Error: ORA-16642: db_unique_name mismatch [message #349943 is a reply to message #349842] Tue, 23 September 2008 09:58 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
I believe you need to connect to the primary database, but it appears that you are connecting to the standby.
Re: Error: ORA-16642: db_unique_name mismatch [message #349968 is a reply to message #349842] Tue, 23 September 2008 11:06 Go to previous message
rolex.mp
Messages: 161
Registered: February 2007
Senior Member
I tried invoking DBMGRL from standby.

Once I tried the same from primary it was working fine.

Thanks for the help.
Previous Topic: About switchover latent
Next Topic: Error while Flashbacking a standby DB
Goto Forum:
  


Current Time: Sat Dec 03 16:03:36 CST 2016

Total time taken to generate the page: 0.09401 seconds