Home » Server Options » Replication » Pb package DBMS_SNAP_INTERNAL invalid in replication 9.2.0.1 (9.2.0.1)
Pb package DBMS_SNAP_INTERNAL invalid in replication 9.2.0.1 [message #349234] Fri, 19 September 2008 07:26 Go to next message
foster06
Messages: 11
Registered: September 2008
Location: NICE
Junior Member
Hello,

I'am trying to make a multi-master replication between 2 bases 9.2.0.1 and 9.2.0.4.

On the 9.2.0.4 instance, no pb.
On the 9.2.0.1 instance, the 3 following packages are invalid :
DBMS_SNAP_INTERNAL
DBMS_UTILITY
DBMS_PSP

I try to pass the scripts catrep.sql and ultrp.sql but no change.

During the execution of the command :
BEGIN
DBMS_REPCAT.CREATE_MASTER_REPGROUP (
gname => 'GM_ADMINISTRATEUR');
END;
/
which create the master group, I have an error becausethe package DBMS_SNAP_INTERNAL is invalid.

Thanks a lot for you help.
Re: Pb package DBMS_SNAP_INTERNAL invalid in replication 9.2.0.1 [message #349290 is a reply to message #349234] Fri, 19 September 2008 13:00 Go to previous messageGo to next message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member

Quote:
'am trying to make a multi-master replication between 2 bases 9.2.0.1 and 9.2.0.4.


Oracle replication recommend for both site you need use same version NOT different.

Babu

[Updated on: Fri, 19 September 2008 13:03] by Moderator

Report message to a moderator

icon7.gif  Re: Pb package DBMS_SNAP_INTERNAL invalid in replication 9.2.0.1 [message #350277 is a reply to message #349234] Wed, 24 September 2008 10:18 Go to previous messageGo to next message
foster06
Messages: 11
Registered: September 2008
Location: NICE
Junior Member
Matalink give me the following solution and it works.


Run as SYSDBA (this should be executed in a RDBMS maintenance window when there is no other user activity):
sqlplus "/ as sysdba"
@catproc.sql
@utlrp.sql
@catrep.sql
@utlrp.sql


After all the SYS package and package body are VALID.

[Updated on: Wed, 24 September 2008 10:21]

Report message to a moderator

Re: Pb package DBMS_SNAP_INTERNAL invalid in replication 9.2.0.1 [message #350343 is a reply to message #350277] Wed, 24 September 2008 15:29 Go to previous message
babuknb
Messages: 1734
Registered: December 2005
Location: NJ
Senior Member


I strongly recommand always use same version both end.

Babu
Previous Topic: Add_Master_Database fails
Next Topic: Database recovery in a replication environment
Goto Forum:
  


Current Time: Sun Dec 04 10:36:14 CST 2016

Total time taken to generate the page: 0.07536 seconds