Home » RDBMS Server » Server Administration » Errors while starting the DB using SPfile (10g/Win XP)
Errors while starting the DB using SPfile [message #348321] Tue, 16 September 2008 07:28 Go to next message
me_maddy
Messages: 31
Registered: April 2008
Member
Hi ALL,

SPfile was removed during the testing and I started the database after making some changes in the pfile, and it works fine.
But when I try to start the database using the SPFILE, it gives an error.

SQL> STARTUP PFILE='D:\oracle\product\10.2.0\admin\orcl\pfile\INITORCL.ORA'
ORACLE instance started.

Total System Global Area  289406976 bytes
Fixed Size                  1248576 bytes
Variable Size             109052608 bytes
Database Buffers          171966464 bytes
Redo Buffers                7139328 bytes
Database mounted.
Database opened.
SQL> create spfile from pfile;

File created.

SQL> shut immediate
Database closed.
Database dismounted.
ORACLE instance shut down.
SQL>
SQL> startup
ORA-01565: error in identifying file 'D:\oracle\product\10.2.0\db_7/dbs/SPFILEORCL.ORA'
ORA-27046: file size is not a multiple of logical block size
OSD-04012: file size mismatch (OS 1541)


The contents of the spfile in $ORACLE_HOME\database are
*.SPFILE='D:\oracle\product\10.2.0\db_7/dbs/SPFILEORCL.ORA'


please suggest!!
Re: Errors while starting the DB using SPfile [message #348404 is a reply to message #348321] Tue, 16 September 2008 11:40 Go to previous messageGo to next message
BlackSwan
Messages: 25046
Registered: January 2009
Location: SoCal
Senior Member
create spfile='D:\oracle\product\10.2.0\db_7/dbs/SPFILEORCL.ORA' from pfile='D:\oracle\product\10.2.0\admin\orcl\pfile\INITORCL.ORA';

shutdown immediate
startup
Re: Errors while starting the DB using SPfile [message #348981 is a reply to message #348321] Thu, 18 September 2008 08:14 Go to previous messageGo to next message
me_maddy
Messages: 31
Registered: April 2008
Member
Thanks for your reply Anacedent,

I have tried it earlier also, but it didnt help.

Below is the output for your reference.

SQL> startup pfile='D:\oracle\product\10.2.0\admin\orcl\pfile\initorcl.ora'
ORACLE instance started.

Total System Global Area  289406976 bytes
Fixed Size                  1248576 bytes
Variable Size             109052608 bytes
Database Buffers          171966464 bytes
Redo Buffers                7139328 bytes
Database mounted.
Database opened.
SQL> create spfile='D:\oracle\product\10.2.0\db_7/dbs/SPFILEORCL.ORA' from pfile='D:\oracle\product\10.2.0\admin\orcl\pfile\INITORCL.ORA';
create spfile='D:\oracle\product\10.2.0\db_7/dbs/SPFILEORCL.ORA' from pfile='D:\oracle\product\10.2.0\admin\orcl\pfile\INITORCL.ORA'
*
ERROR at line 1:
ORA-01078: failure in processing system parameters
LRM-00123: invalid character 146 found in the input file


SQL> create spfile='D:\oracle\product\10.2.0\db_7/dbs/SPFILEORCL.ORA' from pfile='D:\oracle\product\10.2.0\admin\orcl\pfile\INITORCL.ORA';
create spfile='D:\oracle\product\10.2.0\db_7/dbs/SPFILEORCL.ORA' from pfile='D:\oracle\product\10.2.0\admin\orcl\pfile\INITORCL.ORA'
*
ERROR at line 1:
ORA-01078: failure in processing system parameters
LRM-00123: invalid character 146 found in the input file


[B]SQL> create spfile='D:\oracle\product\10.2.0\db_7/dbs/SPFILEORCL.ORA' from pfile;

File created.[/B]

SQL>  create spfile from pfile='D:\oracle\product\10.2.0\admin\orcl\pfile\INITORCL.ORA';
 create spfile from pfile='D:\oracle\product\10.2.0\admin\orcl\pfile\INITORCL.ORA'
*
ERROR at line 1:
ORA-01078: failure in processing system parameters
LRM-00123: invalid character 146 found in the input file


SQL> shut immediate;
Database closed.
Database dismounted.
ORACLE instance shut down.
SQL>
SQL> startup
ORA-03113: end-of-file on communication channel
SQL> startup
ORA-24324: service handle not initialized
ORA-01041: internal error. hostdef extension doesn't exist


Any inputs will be greatly appreciated.
Maddy.
Re: Errors while starting the DB using SPfile [message #349026 is a reply to message #348321] Thu, 18 September 2008 10:42 Go to previous messageGo to next message
BlackSwan
Messages: 25046
Registered: January 2009
Location: SoCal
Senior Member
Please post the contents of the pfile.
I see where Oracle appears to use it to open then DB & not complain
but it appears something inside of it precludes the creation of an spfile.

123, 0, "invalid character %u found in the input file"
// *Cause: A character that is invalid was found in the input file.
// *Action: Specify an input file that contains only valid characters.

[Updated on: Thu, 18 September 2008 10:44] by Moderator

Report message to a moderator

Re: Errors while starting the DB using SPfile [message #349134 is a reply to message #348321] Fri, 19 September 2008 00:57 Go to previous messageGo to next message
me_maddy
Messages: 31
Registered: April 2008
Member
Hi,

Actually I am trying to create a manual standby and for that I have made some changes in the pfile(at primary DB side).

Please see the below pfile contents.

orcl.__db_cache_size=171966464
orcl.__java_pool_size=4194304
orcl.__large_pool_size=4194304
orcl.__shared_pool_size=100663296
orcl.__streams_pool_size=0
*.audit_file_dest='D:\oracle\product\10.2.0/admin/orcl/adump'
*.background_dump_dest='D:\oracle\product\10.2.0/admin/orcl/bdump'
*.compatible='10.2.0.1.0'
*.control_files='D:\oracle\product\10.2.0\oradata\orcl\control01.ctl','D:\oracle\product\10.2.0\oradata\orcl\control02.ctl','D:\oracle\product\10.2.0\oradata\orcl\control03.ctl'
*.core_dump_dest='D:\oracle\product\10.2.0/admin/orcl/cdump'
*.db_block_size=8192
*.db_domain=''
*.db_file_multiblock_read_count=16
*.db_name='orcl'
*.db_recovery_file_dest='D:\oracle\product\10.2.0/flash_recovery_area'
*.db_recovery_file_dest_size=2147483648
*.dispatchers='(PROTOCOL=TCP) (SERVICE=orclXDB)'
*.job_queue_processes=10
*.open_cursors=300
*.pga_aggregate_target=95420416
*.processes=150
*.remote_login_passwordfile='EXCLUSIVE'
*.sga_target=287309824
*.undo_management='AUTO'
*.undo_tablespace='UNDOTBS1'
*.user_dump_dest='D:\oracle\product\10.2.0/admin/orcl/udump'
db_unique_name='orcl'
LOG_ARCHIVE_CONFIG='DG_CONFIG=(ORCL,STAND)'
LOG_ARCHIVE_DEST_1=
'LOCATION=D:\oracle\product\10.2.0\flash_recovery_area\ORCL\ARCHIVELOG
VALID_FOR=(ALL_LOGFILES,ALL_ROLES)
DB_UNIQUE_NAME=ORCL'
LOG_ARCHIVE_DEST_2=
'SERVICE=STAND LGWR ASYNC
VALID_FOR=(ONLINE_LOGFILES,PRIMARY_ROLE)
DB_UNIQUE_NAME=STAND'
LOG_ARCHIVE_DEST_STATE_1=ENABLE
LOG_ARCHIVE_DEST_STATE_2=ENABLE
LOG_ARCHIVE_FORMAT=%t_%s_%r.arc
LOG_ARCHIVE_MAX_PROCESSES=30
remote_login_passwordfile='EXCLUSIVE'
FAL_SERVER=STAND
FAL_CLIENT=ORCL
STANDBY_FILE_MANAGEMENT=AUTO
# Specify the location of the standby DB datafiles followed by the primary location;
DB_FILE_NAME_CONVERT='D:\ORACLE\PRODUCT\10.2.0\ORADATA\STAND','D:\ORACLE\PRODUCT\10.2.0\ORADATA\ORCL'
# Specify the location of the standby DB online redo log files followed by the primary location LOG_FILE_NAME_CONVERT=’D:\ORACLE\PRODUCT\10.2.0\ORADATA\STAND\ONLINELOG’,’D:\ORACLE\PRODUCT\10.2.0\FLASH_RECOVERY_AREA\ORCL\ONLINELOG’,’D:\ORACLE\PRODUCT\10.2.0\ORADATA\STAND\ONLINELOG’,’D:\ORACLE\PRODUCT\10.2.0\FLASH_RECOVERY_AREA\ORCL\ONLINELOG’


Your suggestions are much appreciated.
Regrads
Maddy
Re: Errors while starting the DB using SPfile [message #349345 is a reply to message #348321] Sat, 20 September 2008 09:05 Go to previous messageGo to next message
me_maddy
Messages: 31
Registered: April 2008
Member
Hello Everybody,

Any Suggestions!!

Regards,
Maddy
Re: Errors while starting the DB using SPfile [message #490982 is a reply to message #349345] Fri, 28 January 2011 06:25 Go to previous messageGo to next message
rabcan
Messages: 1
Registered: January 2011
Junior Member
look to logfile (%ora path% \admin\orcl\bdump) after startup from that pfile, you should see ther '?' this is what you are looking for
Re: Errors while starting the DB using SPfile [message #491013 is a reply to message #490982] Fri, 28 January 2011 08:12 Go to previous messageGo to next message
cookiemonster
Messages: 12422
Registered: September 2008
Location: Rainy Manchester
Senior Member
*.audit_file_dest='D:\oracle\product\10.2.0/admin/orcl/adump'

Since when did any operating system have directory paths sperated by a combination of / and \ ?
Re: Errors while starting the DB using SPfile [message #492321 is a reply to message #491013] Sat, 29 January 2011 07:10 Go to previous messageGo to next message
krrish_87
Messages: 8
Registered: September 2010
Location: Mumbai
Junior Member
Hi,

Need to create a Spfile on instance or closed mode.
Otherwise u mention the pfile path when u create a spfile for startup
like eg: create spfile from pfile='D:\oracle\product\10.2.0\admin\orcl\pfile\INITORCL.ORA'

Regards
Krushant.
Re: Errors while starting the DB using SPfile [message #492327 is a reply to message #492321] Sat, 29 January 2011 08:55 Go to previous messageGo to next message
Michel Cadot
Messages: 64139
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Please read OraFAQ Forum Guide and do NOT use IM/SMS speak.

Regards
Michel
Re: Errors while starting the DB using SPfile [message #492331 is a reply to message #492327] Sat, 29 January 2011 09:05 Go to previous messageGo to next message
BlackSwan
Messages: 25046
Registered: January 2009
Location: SoCal
Senior Member
FOLKS, this is a 2.5 year old zombie thread resurrected by newbie.
Please let it Rest In Peace.
Re: Errors while starting the DB using SPfile [message #509158 is a reply to message #492331] Thu, 26 May 2011 05:52 Go to previous messageGo to next message
khurrambhatti
Messages: 1
Registered: May 2011
Location: Karachi
Junior Member
Although this is 2.5 yrs old post but as I just faced this problem and found the solution that's why I wanna share my solution here.

The problem is in the LOG_FILE_NAME_CONVERT line. Any one who face this problem just need to change right hand "smart quote" (0x92) characters with normal single quote characters.
Take a look yourself the difference b/w the quotation marks of LOG_FILE_NAME_CONVERT line and rest of the above lines.

Open your pfile in Microsoft Word and look the difference.


regards,
Khurram Bhatti


[Updated on: Thu, 26 May 2011 06:21] by Moderator

Report message to a moderator

Re: Errors while starting the DB using SPfile [message #509167 is a reply to message #509158] Thu, 26 May 2011 06:22 Go to previous message
Michel Cadot
Messages: 64139
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Thanks for the information.

Regards
Michel
Previous Topic: Deleting unwanted SYS shema objects
Next Topic: table data difference
Goto Forum:
  


Current Time: Fri Dec 09 00:05:37 CST 2016

Total time taken to generate the page: 0.06599 seconds