Home » Developer & Programmer » Forms » Disabling an Required Item (Oracle Forms , 6 i)
Disabling an Required Item [message #347177] Wed, 10 September 2008 23:45 Go to next message
dev88
Messages: 15
Registered: September 2008
Location: SAN JOSE
Junior Member
Hi Gurus,

I am working on a requirement on developing custom form, where i have few required fields in it and a button. The functionality of the button is when button pressed a separate window will open with view only data. Issue is when the first time form is opened and if i go and click the button directly, it is always asking user to enter mandatory fields first. I tried SET_ITEM_PROPERTIES/ SET_ITEM_PROPERTIES to Disable / Inset allow to FALSE but no use. If the required fields are entred and after the button is clicked its working.

Did any one faced this type of requirement and have any clue to over come this. Please let me know.

Thanks
DD.
Re: Disabling an Required Item [message #347189 is a reply to message #347177] Thu, 11 September 2008 00:47 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Define the fields as initially NOT being mandatory and when you leave the 'separate window' use the 'set_item_property' command to make them mandatory.

David
Re: Disabling an Required Item [message #347291 is a reply to message #347177] Thu, 11 September 2008 04:37 Go to previous messageGo to next message
rajy_salim
Messages: 204
Registered: January 2008
Location: Beirut - Lebanon
Senior Member
First, why should they be mandatory if they may be empty?
Second, is the data block in the first form a database block? and is any field bounded? If this is not the case, I think there is no need to make them mandatory when leaving the 'separate window', so that you make them initially NOT mandatory and forget about them.
Re: Disabling an Required Item [message #347476 is a reply to message #347291] Thu, 11 September 2008 18:10 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Rajy, your post gave me food for thought.

DDRAJ, how many blocks do you have in your form? Is the block that contains the 'pop-up' window items first or second? Make it the first. That way Forms will not navigate through the block with the mandatory fields. Also, make sure that the button that causes the window to 'pop-up' is NOT on the block with the mandatory fields but on either the (new) first block or a separate 'control' block.

David
Re: Disabling an Required Item [message #347536 is a reply to message #347177] Fri, 12 September 2008 01:03 Go to previous messageGo to next message
rajy_salim
Messages: 204
Registered: January 2008
Location: Beirut - Lebanon
Senior Member
hehe, LOL! I liked that !! Cool .

But still,
Quote:
The functionality of the button is when button pressed a separate window will open with view only data

Since the separate window will show data to view only, I think that the first data block is a control block just to enter the parameters, and the second is a database block where the data is fetched.
So in the where clause of the second data block, the parameters of the first will interfere. And if this where clause does not take into consideration that these parameters can be null, then no data will be retrieved if no parameters are provided.

Briefly, I think there's no need to make the parameters mandatory, and when the button is pressed, the separate window will be empty.

I hope this is the case, and this is a small hint to solve the problem.

[Updated on: Fri, 12 September 2008 01:05]

Report message to a moderator

Re: Disabling an Required Item [message #347678 is a reply to message #347177] Fri, 12 September 2008 12:09 Go to previous message
dev88
Messages: 15
Registered: September 2008
Location: SAN JOSE
Junior Member
Hi Gurus,

Thank you for your replies. I did fixed the issue, with simple move Smile. Since the button is in the same block of required field it was behaving like that. I have created a new block and moved the button onto new block . It is working fine now.

Thanks
DD.
Previous Topic: WEBUTIL in LOCAL MACHINE
Next Topic: Oracle Forms 6 and Database 9i and Forms 6 and Reprots 6 (merged)
Goto Forum:
  


Current Time: Thu Dec 08 03:53:03 CST 2016

Total time taken to generate the page: 0.23041 seconds