Home » Developer & Programmer » Reports & Discoverer » Problem with Reports 6i & Oracle 9i & Vista 64-bit (Reports 6i, Oracle 9i, Vista 64-bit)
Problem with Reports 6i & Oracle 9i & Vista 64-bit [message #345851] Fri, 05 September 2008 01:53 Go to next message
Messages: 1
Registered: September 2008
Junior Member

we have problem with installed Oracle forms & reports 6i with Oracle 9i
on 64 bit Windows Vista (machine is 64 bit too).
Our stand alone Oracle application written in Oracle forms and reports 6i works fine
with Oracle 9i on Windows XP 32-bit or on Windows Vista 32-bit (on 32-bit hardware).
But after migration to Vista 64-bit, when we try to run any of our reports -
nothing happens, the report hungs.
Do you know what's the reason of this problem?
Can it be 64-bit machine?

Thank you
Re: Problem with Reports 6i & Oracle 9i & Vista 64-bit [message #345859 is a reply to message #345851] Fri, 05 September 2008 02:34 Go to previous messageGo to next message
Messages: 20850
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
I'd say that the reason is in use of unsupported and not certified combination of versions of Oracle and operating system software.

As far as I can tell, Developer Suite 6i, as well as Oracle database 9i were never (and will never be) certified with any version of MS Windows Vista. The fact that your application ran on Vista 32-bit was more product of luck than anything else.

In order to find out which Oracle software versions are certified with certain operating systems, check the Oracle's Certification Matrices.
Re: Problem with Reports 6i & Oracle 9i & Vista 64-bit [message #361512 is a reply to message #345851] Wed, 26 November 2008 12:52 Go to previous messageGo to next message
Messages: 1
Registered: November 2008
Location: Indianapolis
Junior Member

Any update on this?

I'm running into this exact same problem. I too have an Oracle app written in Oracle forms & reports 6i...everything works fine on Windows XP 32-bit and Windows Vista 32-bit (on 32-bit hardware). However on Vista 64-bit (on 64-bit hardware), when I try to run a report; nothing happens, the report hungs...

Here's the catch, I can run the report via the Reports builder no problem.

Any suggestions?

Re: Problem with Reports 6i & Oracle 9i & Vista 64-bit [message #393445 is a reply to message #345851] Sun, 22 March 2009 21:40 Go to previous message
Messages: 1
Registered: March 2009
Junior Member
Pls try to replace the following two dll files in \bin folder by using oracle 6i patch 3 or before version:



You may download the two .dll files from



For more information:




Translation version:

http://babelfish.yahoo.com/translate_url?doit=done&tt=url&intl=1&fr=bf-home&trurl=http%3A%2F%2Foracleforms.blogspot.c om%2F2008%2F04%2Foracle-forms-6i-en-windows-de-64-bits.html&lp=es_en&btnTrUrl=Translate
Previous Topic: Package help
Next Topic: Parameters & single quotes
Goto Forum:

Current Time: Sun Oct 23 12:05:12 CDT 2016

Total time taken to generate the page: 0.28497 seconds