Home » Developer & Programmer » Forms » Menu Proble.....
Menu Proble..... [message #345567] Thu, 04 September 2008 04:04 Go to next message
ziauldba
Messages: 55
Registered: January 2007
Location: Bangladesh
Member

I was add a menu in oracle Form...
it is working when i run for '.fbm'.
when i try to run it from '.fmx' then the menu is not showing in my form...
please give me right solution........


I use Developer 2K
and database Oracle 9i.
Re: Menu Proble..... [message #345652 is a reply to message #345567] Thu, 04 September 2008 06:35 Go to previous messageGo to next message
mudabbir
Messages: 235
Registered: April 2006
Location: Kuwait
Senior Member

Quote:
please give me right solution........


The right solution is

Quote:
SEARCH FOR IT !!!!!!
Re: Menu Proble..... [message #345657 is a reply to message #345652] Thu, 04 September 2008 06:48 Go to previous messageGo to next message
rajy_salim
Messages: 204
Registered: January 2008
Location: Beirut - Lebanon
Senior Member
did you compile the menu, and attach it to correctly to the form?
Re: Menu Proble..... [message #345664 is a reply to message #345567] Thu, 04 September 2008 07:18 Go to previous messageGo to next message
brijal_j_patel
Messages: 28
Registered: May 2007
Location: Surat,India
Junior Member
I want to know, is your .fmb, .fmx, .mmb and. mmx files are in same path? and what u set in forms property : Menu Module?

If your .fmx and .mmx file in same folder then u can avoid full path and only enter menu file name without its extension.

So Put .fmx and .mmx file in same folder then try.
Re: Menu Problem..... [message #346094 is a reply to message #345664] Fri, 05 September 2008 22:38 Go to previous messageGo to next message
ziauldba
Messages: 55
Registered: January 2007
Location: Bangladesh
Member

actually...
My problem is...
i use first form for login it has no menu.....
after ligin i need to get menu...
.................................
If i use the menu in first form then it work...
but if omit the menu from first form for the use in second form it is not showing.............
Re: Menu Problem..... [message #346097 is a reply to message #346094] Fri, 05 September 2008 23:44 Go to previous messageGo to next message
brijal_j_patel
Messages: 28
Registered: May 2007
Location: Surat,India
Junior Member
Suppose you have frmLogin.fmx to login, frmMain.fmx as your main form and mnuMain.mmx as your menu module. All file are at same folder.
Set as following.
1. Form Property Menu Module = mnuMain of frmMain.fmb and compile it.
2. In frmLogin.fmb's Login Button's click event
new_form('mfg');
and compile frmLogin.fmb
3. Now Run frmLogin.fmx and click on Login Button
try this steps. As this work fine at my office
Re: Menu Proble..... [message #346170 is a reply to message #345567] Sat, 06 September 2008 21:17 Go to previous message
ziauldba
Messages: 55
Registered: January 2007
Location: Bangladesh
Member

Thanks brijal_j_patel...
it is working.............
Previous Topic: OLE2 for formating Excel Sheet
Next Topic: Is there any command to set the database item as yes in set_item_property
Goto Forum:
  


Current Time: Fri Dec 02 16:50:53 CST 2016

Total time taken to generate the page: 0.21752 seconds