Home » Developer & Programmer » Reports & Discoverer » Pass Record Group from Forms 10g to Report 10g
Pass Record Group from Forms 10g to Report 10g [message #345388] Wed, 03 September 2008 05:29 Go to next message
raywong9i
Messages: 40
Registered: April 2008
Member
I have a form which will pass a Record Group to the Report as a parameter list, it works in 6i but when I migrate to 10g,
the report cannot be run.

In the Form :

A record group named 'Q_QUERY'with 2 columns named 'APPLY_AGT' & 'STATUS' was built and populated.

l_Param_Name := 'Q_QUERY';
l_Param_Value := 'Q_QUERY';
add_parameter (l_PARMLIST_ID, l_Param_Name, DATA_PARAMETER, l_Param_Value);

Then will call the report using RUN_REPORT_OBJECT
And just before calling the report , I am sure the data is already in the Record Group.


In the Report :

A Queries named 'Q_QUERY' as the Data Source
And there is just 2 columns named 'APPLY_AGT' & 'STATUS'


If I run as above, the system will show "Unable to Run Report".

If I removed the "add_parameter (l_PARMLIST_ID, l_Param_Name, DATA_PARAMETER, l_Param_Value);" statement,
the report can be called successfully.


Am I missed something or it really can't do this in 10g ?

Fyi, I have checked the TEXT_PARAMETER can be pass to report successfully, just DATA_PARAMETER can't.

Please help, thanks!

Re: Pass Record Group from Forms 10g to Report 10g [message #348623 is a reply to message #345388] Wed, 17 September 2008 07:43 Go to previous message
zoltanp
Messages: 58
Registered: March 2005
Location: Hungary
Member
It does not works in multi-tier technology.
Regards,
Zoltan
Previous Topic: recent date
Next Topic: Forms with Informix ODBC
Goto Forum:
  


Current Time: Sun Dec 04 19:05:40 CST 2016

Total time taken to generate the page: 0.07492 seconds