Home » Infrastructure » Windows » TNS-12560 during installation (oracle, 10g, windows 2008 server)
icon8.gif  TNS-12560 during installation [message #345089] Tue, 02 September 2008 05:04 Go to next message
stefan14808
Messages: 3
Registered: September 2008
Junior Member
Hi,

i got a strange problem with my oracle 10g installation on my windows 2008 server.
the first installation went fine, i could create the database and everything went fine.
later we upgraded the server to be the domain controller in our domain.
after this i everything still went fine,
but when i deleted the database and tried to create another database in dbca i got the TNS-12560: TNS:protocol adapter error and no database was created.
i tried pretty much everything i could find to dissolve the error, but nothing worked.
i tried a fresh installation, but got the same error.
even when i tried to install the example database during the installation dialogue, the installer brings up the TNS-12560 error when it tries to create the database.

maybe it is not an oracle problem but a windows/networking problem but i just don't get it.
i hope someone can help me Smile

greetings,
Stefan
Re: TNS-12560 during installation [message #345104 is a reply to message #345089] Tue, 02 September 2008 05:46 Go to previous messageGo to next message
ThomasG
Messages: 3100
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
There are RUMOURS that Oracle advises against running oracle on the domain controller because "funny things" might happen.

I haven't found that in the official documentation anywhere, though.

What is definitely in there is that you have to be logged in as a domain administrator when trying to install oracle on the domain controller, it doesn't work with a local administrator.
Re: TNS-12560 during installation [message #345108 is a reply to message #345104] Tue, 02 September 2008 06:00 Go to previous messageGo to next message
Michel Cadot
Messages: 59291
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Previous versions did not work on a domain controller but now it works but you have to install Oracle and create database with a domain administrator which is not recommended for a security point of view.

Regards
Michel
Re: TNS-12560 during installation [message #345120 is a reply to message #345089] Tue, 02 September 2008 06:31 Go to previous messageGo to next message
stefan14808
Messages: 3
Registered: September 2008
Junior Member
thanks for the answers, i installed oracle as a domain administrator. using another user, who is also a domain administrator did not help
Re: TNS-12560 during installation [message #349407 is a reply to message #345089] Sun, 21 September 2008 09:57 Go to previous messageGo to next message
sub4
Messages: 3
Registered: September 2008
Junior Member
hi,

i've exactely the same problem - and no idea how to solve it.

did you already find a solution?

thx
thomas
Re: TNS-12560 during installation [message #349408 is a reply to message #349407] Sun, 21 September 2008 10:00 Go to previous messageGo to next message
stefan14808
Messages: 3
Registered: September 2008
Junior Member
hi,

no couldnt solve it. we will use vmware and see if oracle is willing to run on a virtual pc
Re: TNS-12560 during installation [message #349410 is a reply to message #349408] Sun, 21 September 2008 10:06 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Have you tried to add the actual account that is the domain administrator to the Local Administrators group and the ORA_DBA group?
Re: TNS-12560 during installation [message #349411 is a reply to message #345089] Sun, 21 September 2008 10:29 Go to previous messageGo to next message
sub4
Messages: 3
Registered: September 2008
Junior Member
@stefan: bad news, i think i'll give up for teh monet.

@ebrian: yes, actual account is member of of these groups. thx anyway.
Re: TNS-12560 during installation [message #349873 is a reply to message #345089] Tue, 23 September 2008 06:37 Go to previous message
sub4
Messages: 3
Registered: September 2008
Junior Member
finally i got oracle running on my 2k8-server.

i created the database manually based on these instructions: http://www.adp-gmbh.ch/ora/admin/creatingdbmanually.html.

the error occurs at the first oradim-statement. I found out, that oracle requires to be logged on as a local administrator on the machine, which is not possible if the server is a domain controller.

i continued anyway and after sarting the service manually i could at least connect once as "/ as sysdba" (not as sys) and continue with db-creation (surprisingly now, since i logged out, i cannot connect anymore ).

but from other machines via tcp i can connect normally to the database.

hope that helps.
Previous Topic: automatic imp/exp
Next Topic: Errors connecting to oracle server thru ADODB
Goto Forum:
  


Current Time: Wed Oct 01 16:08:12 CDT 2014

Total time taken to generate the page: 0.09017 seconds