Home » RDBMS Server » Server Administration » Problem: The install has detected that the primary IP address of the system is DHCP-assigned. (Red hat Linux, Oracle 10g)
Problem: The install has detected that the primary IP address of the system is DHCP-assigned. [message #343133] Tue, 26 August 2008 07:07 Go to next message
ora_2007
Messages: 430
Registered: July 2007
Location: Mumbai
Senior Member
I am installing oracle 10g Server.
The "Checking Network Configuration requirentment" get failed with the following warning.

Quote:
oracle Problem: The install has detected that the primary IP address of the system is DHCP-assigned.

Checking Network Configuration requirements ...
Check complete. The overall result of this check is: Failed <<<<
Problem: The install has detected that the primary IP address of the system is DHCP-assigned.

Recommendation: Oracle supports installations on systems with DHCP-assigned public IP addresses. However, the primary network interface on the system should be configured with a static IP address in order for the Oracle Software
to function properly. See the Installation Guide for more details on installing the software on systems configured with DHCP.


I know that in the Windows there is need to set "Microsoft Loopback Adapter".

But on the linux i do not understand what the things need to set.
Do i need to assign static IP for the machine?

Thanks,

[Updated on: Wed, 27 August 2008 00:53] by Moderator

Report message to a moderator

Re: Problem: The install has detected that the primary IP address of the system is DHCP-assigned. [message #343148 is a reply to message #343133] Tue, 26 August 2008 08:12 Go to previous messageGo to next message
joy_division
Messages: 4641
Registered: February 2005
Location: East Coast USA
Senior Member
I believe so, yes.
Just put a line in the /etc/hosts file with the IP address and machine name.
Re: Problem: The install has detected that the primary IP address of the system is DHCP-assigned. [message #343348 is a reply to message #343133] Wed, 27 August 2008 00:39 Go to previous message
Arju
Messages: 1554
Registered: June 2007
Location: Dhaka,Bangladesh. Mobile:...
Senior Member

A few days ago, I also encounter similar error. Though I had static IP and no DHCP server, oracle still show above message. I had multiple network interfaces to set up for RAC. I think this is a bug. There is something wrong in the script.
Previous Topic: ORA-01031 insufficient privileges
Next Topic: DBMS_IJOB
Goto Forum:
  


Current Time: Wed Dec 07 13:04:07 CST 2016

Total time taken to generate the page: 0.05059 seconds