Home » Server Options » Replication » Problem in running the replication automatically with 1 minute schedule (oracle 10g)
Problem in running the replication automatically with 1 minute schedule [message #342965] Mon, 25 August 2008 12:25
ma_rabii
Messages: 11
Registered: June 2008
Junior Member
I have simulate a replication environment using 3 databases (orc1,orc2 & orc3)

I set the job_queue_process
alter system set job_queue_process = 20

Also I set the schedule for 1 minute,by using the script below:

connect repadmin/repadmin@orc1

BEGIN
DBMS_DEFER_SYS.SCHEDULE_PUSH(
destination => 'orc2',
interval => 'SYSDATE + (1/144)',
next_date => SYSDATE,
parallelism => 1,
execution_seconds => 1500,
delay_seconds => 1200);
END;
/

connect repadmin/repadmin@orc2

--Executing SCHEDULE_PUSH for each dblink
BEGIN
DBMS_DEFER_SYS.SCHEDULE_PUSH(
destination => 'orc1',
interval => 'SYSDATE + (1/144)',
next_date => SYSDATE,
parallelism => 1,
execution_seconds => 1500,
delay_seconds => 1200);
END;
/

BEGIN
DBMS_DEFER_SYS.SCHEDULE_PUSH(
destination => 'orc3',
interval => 'SYSDATE + (1/144)',
next_date => SYSDATE,
parallelism => 1,
execution_seconds => 1500,
delay_seconds => 1200);
END;
/

connect repadmin/repadmin@orc3

--Executing SCHEDULE_PUSH for each dblink
BEGIN
DBMS_DEFER_SYS.SCHEDULE_PUSH(
destination => 'orc1',
interval => 'SYSDATE + (1/144)',
next_date => SYSDATE,
parallelism => 1,
execution_seconds => 1500,
delay_seconds => 1200);
END;
/

BEGIN
DBMS_DEFER_SYS.SCHEDULE_PUSH(
destination => 'orc2',
interval => 'SYSDATE + (1/144)',
next_date => SYSDATE,
parallelism => 1,
execution_seconds => 1500,
delay_seconds => 1200);
END;
/

BEGIN
DBMS_DEFER_SYS.SCHEDULE_PUSH(
destination => 'orc3',
interval => 'SYSDATE + (1/144)',
next_date => SYSDATE,
parallelism => 1,
execution_seconds => 1500,
delay_seconds => 1200);
END;
/
but when I insert a row in my table test1 in orc1 and commit it
I can not see this row in orc2 or orc3.
Anybody has a clue?

Thanks

Mery


Edit:
I Made it work(I mean the above question).
I installed OEM and I found out that the problem is because the SECHEDULE_PUSH script had not worked and it was in state of unscheduled I set the time manually it works but the problem is when I use the API for setting the SCHEDULE it does not work.

BEGIN
DBMS_DEFER_SYS.SCHEDULE_PUSH(
destination => 'orc3',
interval => 'SYSDATE + (1/144)',
next_date => SYSDATE,
parallelism => 1,
execution_seconds => 1500,
delay_seconds => 1200);
END;
/
it doesn't change?!!!!Any clue?

[Updated on: Mon, 25 August 2008 17:27]

Report message to a moderator

Previous Topic: What is the difference in using updateable materialized view and multi master asynce
Next Topic: Problem in setting replication Table does not exist or is invalid
Goto Forum:
  


Current Time: Fri Dec 02 22:53:39 CST 2016

Total time taken to generate the page: 0.16102 seconds