Home » SQL & PL/SQL » SQL & PL/SQL » API Error (Oracle HRMS R12)
API Error [message #342078] Thu, 21 August 2008 05:11 Go to next message
sourabh_2503
Messages: 3
Registered: August 2008
Junior Member
Hello,

Please help in the topic below:

When I am trying to execute the API below, I am getting an error as

Error: PLS-00306: wrong number or types of arguments in call to 'CREATE_COST_ALLOCATION'

The API is


PAY_COST_ALLOCATION_API.CREATE_COST_ALLOCATION
(p_validate => L_VALID
,p_effective_date => L_EFFECTIVE_DATE
,p_assignment_id => '2046'--L_ASSIGNMENT_ID
,p_proportion => L_PROPORTION
,p_business_group_id => L_BUSN_GRP_ID
,p_segment1 => '101'
,p_segment2 => '100000'
,p_segment3 => '999'
,p_segment4 => '1100'--L_DEPARTMENT
,p_segment5 => '1004'--L_PROJECT
,p_segment6 => '9999'
,p_segment7 => '999'
,p_segment8 => '9999'
,p_segment9 => '999999'
/* ,p_segment10 => NULL
,p_segment11 => NULL
,p_segment12 => NULL
,p_segment13 => NULL
,p_segment14 => NULL
,p_segment15 => NULL
,p_segment16 => NULL
,p_segment17 => NULL
,p_segment18 => NULL
,p_segment19 => NULL
,p_segment20 => NULL
,p_segment21 => NULL
,p_segment22 => NULL
,p_segment23 => NULL
,p_segment24 => NULL
,p_segment25 => NULL
,p_segment26 => NULL
,p_segment27 => NULL
,p_segment28 => NULL
,p_segment29 => NULL
,p_segment30 => NULL*/
,p_concat_segments => L_CONCAT_SEG--'1100-1004' --L_CONCAT_SEG
,p_request_id => L_REQUEST_ID
,p_program_application_id => L_PROG_APP_ID
,p_program_id => L_PROG_ID
,p_program_update_date => L_PROG_UP_DATE
,p_combination_name => L_COMB_NAME
,p_cost_allocation_id => L_COST_ALLOCATION_ID
,p_effective_start_date => L_EFFECTIVE_DATE
,p_effective_end_date => L_EFFECTIVE_DATE
,p_cost_allocation_keyflex_id => L_COST_ALLOCATION_KF_ID
,p_object_version_number => L_OBJECT_VERSION_NUMBER
);
Re: API Error [message #342083 is a reply to message #342078] Thu, 21 August 2008 05:20 Go to previous messageGo to next message
Michel Cadot
Messages: 64111
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
It seems to me the error message is quite clear: check the number and types of your parameters.

Regards
Michel
Re: API Error [message #342086 is a reply to message #342078] Thu, 21 August 2008 05:22 Go to previous messageGo to next message
sourabh_2503
Messages: 3
Registered: August 2008
Junior Member

Hello,

I have checked the number and types of arguments. They are correct. Please help.


Sourabh
Re: API Error [message #342089 is a reply to message #342086] Thu, 21 August 2008 05:26 Go to previous messageGo to next message
Michel Cadot
Messages: 64111
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
I know Oracle, I don't know you.
I think you are wrong and Oracle is right.
Maybe you just don't call what you think you call, maybe you just don't see the error, check again.

Regards
Michel
Re: API Error [message #342093 is a reply to message #342078] Thu, 21 August 2008 05:41 Go to previous message
sourabh_2503
Messages: 3
Registered: August 2008
Junior Member
The error is gone....
Thanks for da reply.. Smile
Previous Topic: Invalid Cursor
Next Topic: Column Value and Data Type of column
Goto Forum:
  


Current Time: Mon Dec 05 20:58:02 CST 2016

Total time taken to generate the page: 0.12642 seconds