Home » Developer & Programmer » Forms » List Box after populate_list() behaviour (Forms 6i)  () 1 Vote
List Box after populate_list() behaviour [message #341680] Tue, 19 August 2008 23:22 Go to next message
didiera
Messages: 134
Registered: August 2007
Location: Mauritius
Senior Member
Hi guys,

I have a problem here. In a forms at some point, I have a List Box of type Poplist that gets its values repopulated. An end user has pointed out a bug that happens just after this repopulation. Even though the list is showing the first new value of the list, whenever I try evaluating its currently selected value, it gives me the previously selected one it seems. If you check the screen dump attached you will see that my list box I_USERNAME_COPY has the value "AADAM" while it's actually showing "ADUBOIS" -these are just user names actually.

So my question is: Has anyone come across this before and does anyone have a clue ?

Note also that this only happens when, just after repopulation, I don't select anything from the list box and try to redo the same process with the currently selected username.

best regards,
Didier
Re: List Box after populate_list() behaviour [message #341719 is a reply to message #341680] Wed, 20 August 2008 01:51 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Put a 'synchronize' into your code.

David
Previous Topic: oracle 10g form running
Next Topic: query for saving the called report
Goto Forum:
  


Current Time: Sun Dec 11 06:08:23 CST 2016

Total time taken to generate the page: 0.04327 seconds