Home » Developer & Programmer » Reports & Discoverer » Unable to connect to the Report server (Oracle 10g 10.2 / Developer Suite 10g 10.1.2 / OS window WP professional)
Unable to connect to the Report server [message #341648] Tue, 19 August 2008 15:10 Go to next message
woravee
Messages: 1
Registered: August 2008
Junior Member
Hi,

I'm facing the problem when try to run report from Oracle form.

I use Oracle 10g and Developer 10g.

I start rwserver with command line
> RWSERVER SERVER=localrepserver BATCH=yes

and my code for run report from form is

DECLARE

repid REPORT_OBJECT;
v_rep VARCHAR2(100);

BEGIN

repid := find_report_object('ac_code_rep');

SET_REPORT_OBJECT_PROPERTY(repid,REPORT_EXECUTION_MODE,RUNTIME);
SET_REPORT_OBJECT_PROPERTY(repid,REPORT_COMM_MODE,SYNCHRONOUS);
SET_REPORT_OBJECT_PROPERTY(repid,REPORT_DESNAME,'C:\PROJECT\REPORT\TEST3.HTML');
SET_REPORT_OBJECT_PROPERTY(repid,REPORT_DESTYPE,FILE);
SET_REPORT_OBJECT_PROPERTY(repid,REPORT_DESFORMAT,'html');
SET_REPORT_OBJECT_PROPERTY(repid,REPORT_SERVER,'localrepserver');

v_rep := RUN_REPORT_OBJECT(repid);
WEB.SHOW_DOCUMENT('file:///C:\PROJECT\REPORT\TEST3.HTML','_blank');

end;


When I run this code in form, I've got the error message
"FRM-41213: Unable to connect to the Report server localrepserver"

But as I look in the window task manager, the "reserver.exe" is still running.

I have no idea how to solve this error.

Could anyone kindly help me on this,please

thank you very much

Regards,
Re: Unable to connect to the Report server [message #343655 is a reply to message #341648] Wed, 27 August 2008 14:36 Go to previous message
msaleem
Messages: 37
Registered: November 2006
Location: Pakistan
Member

hello dear

please follow the following code, update following code as per your reuirement

Thanks
Saleem(Pakistan)

declare
rep_name varchar2 := 'mybankrep';
plist paramlist) IS
vrepid report_object;
vrep varchar2(100);
tmpREP_status varchar2(30);
server_name varchar2(200) := 'dbs';
server_port number := 8889;
rep_server varchar2(200) := 'rep_ssc';
BEGIN
vrepid := FIND_REPORT_OBJECT (rep_name);
SET_REPORT_OBJECT_PROPERTY(vrepid,REPORT_EXECUTION_MODE,BATCH);
SET_REPORT_OBJECT_PROPERTY(vrepid,REPORT_COMM_MODE,SYNCHRONOUS);
SET_REPORT_OBJECT_PROPERTY(vrepid,REPORT_DESTYPE,CACHE);
SET_REPORT_OBJECT_PROPERTY(vrepid,REPORT_DESFORMAT,'PDF');
SET_REPORT_OBJECT_PROPERTY(vrepid,REPORT_SERVER,rep_server);
SET_REPORT_OBJECT_PROPERTY(vrepid,REPORT_OTHER,'paramform=NO');
vrep:= RUN_REPORT_OBJECT(vrepid,plist);
tmpREP_status:= REPORT_OBJECT_STATUS(vrep);
WHILE tmpREP_status in ('RUNNING','OPENING_REPORT','ENQUEUED')
LOOP
tmpREP_status:= report_object_status(vRep);
END LOOP;
IF (tmpREP_status = 'FINISHED') THEN
web.show_document( 'http://'||server_name||':'||server_port||'/reports/rwservlet/getjobid'
|| SUBSTR (vrep, INSTR (vrep, '_', -1) + 1)||'?server='||rep_server,'_blank');
end if;
end;
Previous Topic: How to run report securely from Unix shell / sqlplus?
Next Topic: Hide selection window of report's 10g format
Goto Forum:
  


Current Time: Wed Dec 07 08:26:27 CST 2016

Total time taken to generate the page: 0.09842 seconds