Home » Infrastructure » Windows » Unable to connect oracle 9i database from ASP.NET (64 bit Windows Server 2008 Std. Ed.)
Unable to connect oracle 9i database from ASP.NET [message #341384] Mon, 18 August 2008 11:48 Go to next message
puzanamatya
Messages: 4
Registered: August 2008
Junior Member
I've installed 10203_vista_w2k8_x86_production_client oracle client on Windows Server 2008 std ed x64. Using this client i could connect to my Oracle 9i database. I've developed a webpart for Microsoft Sharepoint service running on the same machine which gets data from oracle 9i. But I'm getting error like "Attempt to load Oracle client libraries threw BadImageFormatException. This problem will occur when running in 64 bit mode with the 32 bit Oracle client components installed." I've used System.data.oracleclient to connect oracle in my webpart and ASP.NET is 64 bit.

Please help me!!

Regards,
Pujan

[Updated on: Mon, 18 August 2008 12:07]

Report message to a moderator

Re: Unable to connect oracle 9i database from ASP.NET [message #341643 is a reply to message #341384] Tue, 19 August 2008 14:23 Go to previous messageGo to next message
puzanamatya
Messages: 4
Registered: August 2008
Junior Member
Previously i thought it's due to version issue of .NET data provider for oracle. But it wasn't. I unregistered asp.net x64 framework and installed it again and ran it on WOW64 mode. Now it's working fine. Smile
Re: Unable to connect oracle 9i database from ASP.NET [message #342027 is a reply to message #341643] Thu, 21 August 2008 01:57 Go to previous message
puzanamatya
Messages: 4
Registered: August 2008
Junior Member
puzanamatya wrote on Wed, 20 August 2008 01:08
I unregistered asp.net x64 framework and installed it again and ran it on WOW64 mode. Also installed win64_11gR1_client Oracle
Clietnt. Now it's working fine. Smile

Previous Topic: How To Install Jinitiator ( oajint ) on 64 bit Windows XP
Next Topic: How To install Jinitiator 64 bit Windows Xp
Goto Forum:
  


Current Time: Sat Dec 03 14:11:43 CST 2016

Total time taken to generate the page: 0.07796 seconds