Home » Infrastructure » Other Operating Systems » External procedure problem - lost RPC connection ORA-28576
External procedure problem - lost RPC connection ORA-28576 [message #340765] Thu, 14 August 2008 03:50 Go to next message
kitmaster
Messages: 5
Registered: August 2008
Junior Member
When I try to start external procedure I get this error ORA-28576: lost RPC connection to external procedure agent
tnsping EXTPROC_CONNECTION_DATA works.
Listner.ora:
###
# OE390 listener
###
LISTENER =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP)(HOST = AS16)(PORT = 1522))
)

SID_LIST_LISTENER =
(SID_LIST =
(SID_DESC =
(SID_NAME = EXTPROC)
(ORACLE_HOME = /oracle9)
(ENVS = "EXTPROC_DLLS=ANY")
(PROGRAM = extproc)
)
)

STARTUP_WAIT_TIME_LISTENER=1
CONNECT_TIMEOUT_LISTENER=2
TRACE_LEVEL_LISTENER=SUPPORT
TRACE_DIRECTORY_LISTENER=/oracle9/network/admin/trace
TRACE_FILE_LISTENER=lis.trc
LOG_DIRECTORY_LISTENER=/oracle9/network/admin/trace
LOG_FILE_LISTENER=tns.log
#LOGGING_LISTENER=ON
#OPS_DOLLAR_LOGIN_ALLOWED=(OOOO)



tnsnames.ora


EXTPROC_CONNECTION_DATA =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = AS16)(PORT = 1522))
(CONNECT_DATA =
(SID = EXTPROC)
)
)
SCHL =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP) (HOST = AS16) (PORT = 1501))
)
(CONNECT_DATA =
(SERVICE_NAME = SCHL)
)
)


Any ideas?

[Updated on: Thu, 14 August 2008 03:54]

Report message to a moderator

Re: External procedure problem - lost RPC connection ORA-28576 [message #341274 is a reply to message #340765] Mon, 18 August 2008 02:21 Go to previous messageGo to next message
azeleny
Messages: 4
Registered: June 2006
Junior Member
Hi,

try to follow Oracle metalink note: 203744.1 z/OS: Sample Set up of External Procedures

Regards Ales
Re: External procedure problem - lost RPC connection ORA-28576 [message #341276 is a reply to message #341274] Mon, 18 August 2008 02:30 Go to previous messageGo to next message
kitmaster
Messages: 5
Registered: August 2008
Junior Member
Can't you send me this article, please? Don't have metalink password yet. terra24@list.ru

[Updated on: Mon, 18 August 2008 02:33]

Report message to a moderator

Re: External procedure problem - lost RPC connection ORA-28576 [message #341281 is a reply to message #341276] Mon, 18 August 2008 03:09 Go to previous messageGo to next message
kitmaster
Messages: 5
Registered: August 2008
Junior Member
I got access to metalink. But this steps I did. And it it isn't work yet.
Re: External procedure problem - lost RPC connection ORA-28576 [message #341290 is a reply to message #340765] Mon, 18 August 2008 04:03 Go to previous messageGo to next message
azeleny
Messages: 4
Registered: June 2006
Junior Member
We had lot's of problems with extrpoc, but if You follow exactly steps in mentioned article, it worked.

Another useful metalink note is 70638.1 External Procedures - Troubleshooting ORA-28575 Errors

One of errors we had was problem with accidentally deleted extproc binary.

Kind regards Ales
Re: External procedure problem - lost RPC connection ORA-28576 [message #341300 is a reply to message #341290] Mon, 18 August 2008 04:23 Go to previous messageGo to next message
kitmaster
Messages: 5
Registered: August 2008
Junior Member
Does your external procedure work on oracle 9 also?
Re: External procedure problem - lost RPC connection ORA-28576 [message #341310 is a reply to message #341300] Mon, 18 August 2008 05:28 Go to previous messageGo to next message
azeleny
Messages: 4
Registered: June 2006
Junior Member
Yes, we are runnig extproc on 9i and 10g.

ales
Re: External procedure problem - lost RPC connection ORA-28576 [message #341313 is a reply to message #341310] Mon, 18 August 2008 05:42 Go to previous message
kitmaster
Messages: 5
Registered: August 2008
Junior Member
Can't you show me your test.sql,listener.ora,sqlnet.ora and tnsnames.ora? May be you make some changes in this example. I have the same error, just don't understand what should I change. Can you also show your LIBPATH?
P.S. the system is z/os, not os/390.
Previous Topic: lbuilder on z/OS
Next Topic: JCL which is calling SQLPLUS is giving error
Goto Forum:
  


Current Time: Mon Jul 28 04:33:06 CDT 2014

Total time taken to generate the page: 0.05525 seconds