Home » Infrastructure » Linux » libclntsh.so incompatible for DBD::Oracle install (Oracle, 10.2.0.1 / DBD::Oracle, Linux x86 64 bits)
libclntsh.so incompatible for DBD::Oracle install [message #340083] Mon, 11 August 2008 06:33
Opsw
Messages: 1
Registered: August 2008
Junior Member
Hi all,

I have this error for installing DBI:Oracle for Perl. Information about my environment are below.
I do not understand why the library seems "incompatible".
Thank you very much for your help.

Opsw


-----------------
ERROR
-----------------
[...DBD-Oracle-1.22]$ make
rm -f blib/arch/auto/DBD/Oracle/Oracle.so
gcc -shared Oracle.o dbdimp.o oci8.o -L/Soft/oracle/1020/lib/ -L/Soft/oracle/1020/rdbms/lib/ -lclntsh `cat /Soft/oracle/1020/lib/sysliblist` -ldl -lm -o blib/arch/auto/DBD/Oracle/Oracle.so
/usr/bin/ld: skipping incompatible /Soft/oracle/1020/lib//libclntsh.so when searching for -lclntsh
/usr/bin/ld: cannot find -lclntsh
collect2: ld returned 1 exit status
make: *** [blib/arch/auto/DBD/Oracle/Oracle.so] Error 1

--------------
INFO
--------------
OS : x86_64-linux
Oracle : 10.2.0.1.0
Perl : lib64/perl5/5.8.5/x86_64-linux-thread-multi
DBI version : 1.602
DBD version : 1.22

ORACLE_LIBRARY=/Soft/oracle/1020/lib
ORACLE_BASE=/Soft/oracle
ORACLE_HOME=/Soft/oracle/1020

LD_LIBRARY_PATH=/Soft/oracle/1020/lib
PATH=/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/home/pas_exp/bin

lrwxrwxrwx 1 ora1020 dba 17 Mar 16 10:56 /Soft/oracle/1020/lib/libclntsh.so -> libclntsh.so.10.1
-rwxr-xr-x 1 ora1020 dba 18435916 Feb 18 16:37 /Soft/oracle/1020/lib/libclntsh.so.10.1
Previous Topic: Oracle on Ubuntu
Next Topic: Ora-24324 Ora-1041 error on
Goto Forum:
  


Current Time: Wed Oct 22 08:34:21 CDT 2014

Total time taken to generate the page: 0.08778 seconds