Home » RDBMS Server » Performance Tuning » Index is used still problem
Index is used still problem [message #339120] Wed, 06 August 2008 17:43 Go to next message
bubbly
Messages: 5
Registered: August 2008
Junior Member
Hi ... I am working with 10g R2 (10.2.0.3)

I have issue related to performance.
My Index is working still its taking time for my query to fetch result.

Please remember my Index is not fragmented
Re: Index is used still problem [message #339123 is a reply to message #339120] Wed, 06 August 2008 17:52 Go to previous messageGo to next message
BlackSwan
Messages: 25037
Registered: January 2009
Location: SoCal
Senior Member
http://www.orafaq.com/forum/t/88153/0/
Please read & follow posting guidelines as stated in URL above

http://www.orafaq.com/forum/t/84315/74940/
which of the suggestions in URL above have you tried & what were the results?


>Please remember my Index is not fragmented
OK, I'll remember that.

My car won't go.
Please remember my car has a full tank of gas.
Tell me how to make my car go.

Why do you expect assistance with SQL we have not even seen?


Re: Index is used still problem [message #339126 is a reply to message #339123] Wed, 06 August 2008 18:05 Go to previous messageGo to next message
bubbly
Messages: 5
Registered: August 2008
Junior Member
Right now i am not in front of my server ... so not able to put SQL on this forum...

But suppose if my query is fine, it is using index still problem why?
Re: Index is used still problem [message #339128 is a reply to message #339120] Wed, 06 August 2008 18:12 Go to previous messageGo to next message
BlackSwan
Messages: 25037
Registered: January 2009
Location: SoCal
Senior Member
http://download.oracle.com/docs/cd/B19306_01/server.102/b14211/toc.htm

>But suppose if my query is fine, it is using index still problem why?

How do you know the index is being used?
How do you know the query is "fine"?
Why do you conclude a problem exists?
Some queries take longer to complete than others.
It depends.

You don't know, what you don't know.
If SQL tuning was easy, you would not be here.

[Updated on: Wed, 06 August 2008 18:13] by Moderator

Report message to a moderator

Re: Index is used still problem [message #339153 is a reply to message #339128] Wed, 06 August 2008 22:27 Go to previous messageGo to next message
rleishman
Messages: 3724
Registered: October 2005
Location: Melbourne, Australia
Senior Member
If I had to guess (and since you have not provided any information, I DO have to), I would say the index is scanning too much data:

See here.

Ross Leishman
Re: Index is used still problem [message #339269 is a reply to message #339153] Thu, 07 August 2008 03:36 Go to previous message
sunil_v_mishra
Messages: 506
Registered: March 2005
Senior Member
May be due to clustering factor your are facing problem though your query & index are fine...

Bubbly kindly check it in dba_index.
Previous Topic: How to estimate query response time and number of rows without executing query
Next Topic: UNION and UNION ALL discrepancy
Goto Forum:
  


Current Time: Mon Dec 05 11:19:09 CST 2016

Total time taken to generate the page: 0.07107 seconds