Home » Developer & Programmer » Forms » Installing Fonts / Copy a file to Windows Directory
Installing Fonts / Copy a file to Windows Directory [message #338672] Tue, 05 August 2008 10:52 Go to next message
Signum
Messages: 13
Registered: July 2008
Junior Member
Hi !

I have a problem with fonts. One of my reports need a font to display correctly. This font is on the AS. From Forms, I call the report and I use the procedure "WEBUTIL_FILETRANSFER.AS_To_Client", "C:\windows\fonts" (AS side) to "C:\windows\fonts" (client side), but there's no file transferred. In fact, when I use "C:\", it works fine.
It seems I can't use "C:\windows\fonts\" as a directory for the client. I also tried to copy the font in a directory (one that works) and use "WEBUTIL_File.Copy_File" to "C:\Windows\Fonts" but it doesn't work either. I'm sure I have admin rights.

Is there another way to install font ? (for Windows)

For info, I'm using Forms 10g and Database 10g. My OS is Windows XP SP2 and I tried with IE7 and Firefox 3.0 browsers.

[Updated on: Tue, 05 August 2008 10:53]

Report message to a moderator

Re: Installing Fonts / Copy a file to Windows Directory [message #339602 is a reply to message #338672] Thu, 07 August 2008 21:38 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Where is the report running? On the AS or client?

David
Re: Installing Fonts / Copy a file to Windows Directory [message #339926 is a reply to message #338672] Sat, 09 August 2008 16:51 Go to previous messageGo to next message
Signum
Messages: 13
Registered: July 2008
Junior Member
The report is running on client side ^^ I use Run_Report_Object and then Web.Show_Document to show the report.
Re: Installing Fonts / Copy a file to Windows Directory [message #341220 is a reply to message #339926] Sun, 17 August 2008 21:21 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
What happens when you only use the 'web.show_document' command as per the many examples in this forum?

David
Re: Installing Fonts / Copy a file to Windows Directory [message #341521 is a reply to message #338672] Tue, 19 August 2008 03:35 Go to previous message
Signum
Messages: 13
Registered: July 2008
Junior Member
If I only use the "Web.Show_Document" command, I have to change the URL and it works but with the problem of fonts.

However, I just found a solution. I have to write something in Windows registry (on client side) in order to make fonts working.

In Windows registry, I add a new string in "HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Fonts". Its name is the name of the font and the value is the file name of the font. Then, I can copy font files to "C:\Windows\Fonts". But, the computer (client side) has to be restarted.
Previous Topic: firefox bad gateway
Next Topic: Shift text on next line in text item
Goto Forum:
  


Current Time: Thu Dec 08 04:08:26 CST 2016

Total time taken to generate the page: 0.07469 seconds