Home » Infrastructure » Windows » CPU usage question (Oracle 10G R2 64x, 10.2.0, Win 2003 Ent 64X)
CPU usage question [message #337325] Wed, 30 July 2008 10:06 Go to next message
sbaker
Messages: 12
Registered: April 2006
Junior Member
Just a quick question here. It might sound like a tuning issue, but right now I'm just looking for a hardware answer.

I'm running a IBM x21HS Blade that has 16GB RAM, 2 Quad Core 2.5GHZ Xeon processors. 10G R2 is installed and running like a
dream on it. UNTIL! I ran an inventory query. Now on our 8i system the query takes like 30secs. On our 10G system it's taking 3 hours...... ASH report is telling me its CPU.

Now for the hardware question Smile I've noticed while this process is running, it's only using 1 of the 8 cores. 13% processor utilization...

Is there anyway for force oracle to use more of the processing cores? IF not it's a total waste of hardware.

Thanks for any insight Smile
Re: CPU usage question [message #337330 is a reply to message #337325] Wed, 30 July 2008 10:14 Go to previous messageGo to next message
BlackSwan
Messages: 25046
Registered: January 2009
Location: SoCal
Senior Member
How can a single thread/process use more than 1 CPU at a time?
Unless or until some hypervisor can intelligently split the processing to parallelize it only a single core/CPU will be utilized.
Re: CPU usage question [message #337333 is a reply to message #337330] Wed, 30 July 2008 10:17 Go to previous message
sbaker
Messages: 12
Registered: April 2006
Junior Member
Dang, lol, It's still to early for me today.

Anacedent thank you for stating the obvious. Smile lol off for more coffee.

I'm going to have to look at I/O and some tuning for this issue. Again I apolagize for the simple mindedness this morning. lol.
Previous Topic: Oracle lite Client Installation
Next Topic: Problem in Developer Suite 10G
Goto Forum:
  


Current Time: Fri Dec 09 04:00:36 CST 2016

Total time taken to generate the page: 0.12562 seconds