Home » RDBMS Server » Enterprise Manager » Manual OEM install issue - (Oracle 10G 10.2.0 64x, Win 2003 Ent 64x)
icon8.gif  Manual OEM install issue - [message #336280] Fri, 25 July 2008 08:57 Go to next message
sbaker
Messages: 12
Registered: April 2006
Junior Member
Hey everyone, I've got an issue I've been banging my head against the wall here for sometime. I created a test database about a month ago and used the manual emca util to install OEM and it went perfect.

Now I've installed the test database on a brand new server and this time when I try to install OEM I'm getting errors.

Now the installation of the 2 test databases were the same. Installed oracle application, used our ERP vendors DB create script (cannot use DBCA). Import a dmp from production oracle DB (8.1.7). Do some clean up, and thats it. Once tested to ensure everything was ok is when I tried to install OEM. As stated first time it worked great, this time its not.

I've gone trough the drop and create process many many times and it's still not working.

Below is my complete log dump. Any advice would be MUCH helpful.
Thank you for your time.


Jul 24, 2008 5:11:37 PM oracle.sysman.emcp.ParamsManager setFlag
CONFIG: Flag '-config' set to true
Jul 24, 2008 5:11:37 PM oracle.sysman.emcp.ParamsManager setFlag
CONFIG: Flag 'UPDATE_EMAIL' set to true
Jul 24, 2008 5:11:37 PM oracle.sysman.emcp.ParamsManager setFlag
CONFIG: Flag 'dbcontrol' set to true
Jul 24, 2008 5:11:37 PM oracle.sysman.emcp.ParamsManager setFlag
CONFIG: Flag 'db' set to true
Jul 24, 2008 5:11:37 PM oracle.sysman.emcp.ParamsManager setFlag
CONFIG: Flag 'create' set to true
Jul 24, 2008 5:11:37 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: ORACLE_HOME value: C:\oracle\product\10.2.0\db_1
Jul 24, 2008 5:11:37 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
Jul 24, 2008 5:11:37 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: EM_HOME value: C:\oracle\product\10.2.0\db_1
Jul 24, 2008 5:11:40 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: SID value: test1
Jul 24, 2008 5:11:40 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
Jul 24, 2008 5:11:40 PM oracle.sysman.emcp.util.ClusterUtil getLocalNode
CONFIG: Cluster.isCluster: false. Skip call to getLocalNode
Jul 24, 2008 5:11:40 PM oracle.sysman.emcp.util.ClusterUtil getLocalNode
CONFIG: isLocalNodeDone: true localNode: null
Jul 24, 2008 5:11:40 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
Jul 24, 2008 5:11:40 PM oracle.sysman.emcp.util.DBControlUtil isDBConsoleConfigured
CONFIG: Sid: test1 Host: testblade.microtekmed.com Node: null OH: C:\oracle\product\10.2.0\db_1 isDBC: false
Jul 24, 2008 5:11:40 PM oracle.sysman.emcp.util.CentralAgentUtil isCentralAgentConfigured
CONFIG: Sid: test1 Host: testblade.microtekmed.com Node: null OH: C:\oracle\product\10.2.0\db_1 agentHome: null isCentral: false
Jul 24, 2008 5:11:40 PM oracle.sysman.emcp.util.CentralAgentUtil isCentralAgentConfigured
CONFIG: Sid: test1 Host: testblade.microtekmed.com Node: null OH: C:\oracle\product\10.2.0\db_1 agentHome: null isCentral: false
Jul 24, 2008 5:11:40 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter SYS_PWD.
Jul 24, 2008 5:11:40 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine connecting with SID: test1, oracleHome: C:\oracle\product\10.2.0\db_1, and user:
Jul 24, 2008 5:11:41 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: ORA-01031: insufficient privileges

oracle.sysman.assistants.util.sqlEngine.SQLFatalErrorException: ORA-01031: insufficient privileges
at oracle.sysman.assistants.util.sqlEngine.SQLEngine.executeImpl(SQLEngine.java:1467)
at oracle.sysman.assistants.util.sqlEngine.SQLEngine.connect(SQLEngine.java:814)
at oracle.sysman.emcp.util.GeneralUtil.initSQLEngine(GeneralUtil.java:363)
at oracle.sysman.emcp.DatabaseChecks.checkDbAvailabilityImpl(DatabaseChecks.java:101)
at oracle.sysman.emcp.DatabaseChecks.checkDbAvailability(DatabaseChecks.java:143)
at oracle.sysman.emcp.DatabaseChecks.isASMDb(DatabaseChecks.java:715)
at oracle.sysman.emcp.EMConfigAssistant.getParamsWarnsList(EMConfigAssistant.java:1793)
at oracle.sysman.emcp.EMConfigAssistant.getDisplayAndPromptWarnsParms(EMConfigAssistant.java:2276)
at oracle.sysman.emcp.EMConfigAssistant.performConfiguration(EMConfigAssistant.java:928)
at oracle.sysman.emcp.EMConfigAssistant.statusMain(EMConfigAssistant.java:463)
at oracle.sysman.emcp.EMConfigAssistant.main(EMConfigAssistant.java:412)
Jul 24, 2008 5:11:41 PM oracle.sysman.emcp.DatabaseChecks isASMDb
CONFIG: Database instance unavailable.
oracle.sysman.emcp.exception.DatabaseUnavailableException: Database instance unavailable.

at oracle.sysman.emcp.DatabaseChecks.throwDBUnavailableException(DatabaseChecks.java:131)
at oracle.sysman.emcp.DatabaseChecks.checkDbAvailabilityImpl(DatabaseChecks.java:124)
at oracle.sysman.emcp.DatabaseChecks.checkDbAvailability(DatabaseChecks.java:143)
at oracle.sysman.emcp.DatabaseChecks.isASMDb(DatabaseChecks.java:715)
at oracle.sysman.emcp.EMConfigAssistant.getParamsWarnsList(EMConfigAssistant.java:1793)
at oracle.sysman.emcp.EMConfigAssistant.getDisplayAndPromptWarnsParms(EMConfigAssistant.java:2276)
at oracle.sysman.emcp.EMConfigAssistant.performConfiguration(EMConfigAssistant.java:928)
at oracle.sysman.emcp.EMConfigAssistant.statusMain(EMConfigAssistant.java:463)
at oracle.sysman.emcp.EMConfigAssistant.main(EMConfigAssistant.java:412)
Jul 24, 2008 5:11:41 PM oracle.sysman.emcp.ParamsManager setFlag
CONFIG: Flag 'asm_db' set to false
Jul 24, 2008 5:11:43 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: PORT value: 1521
Jul 24, 2008 5:11:44 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter SYS_PWD.
Jul 24, 2008 5:11:44 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine connecting with SID: test1, oracleHome: C:\oracle\product\10.2.0\db_1, and user: SYS
Jul 24, 2008 5:11:44 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine created successfully and connected
Jul 24, 2008 5:11:47 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine connecting with SID: test1, oracleHome: C:\oracle\product\10.2.0\db_1, and user: DBSNMP
Jul 24, 2008 5:11:47 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine created successfully and connected
Jul 24, 2008 5:11:50 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: EMAIL_ADDRESS value:
Jul 24, 2008 5:11:50 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: MAIL_SERVER_NAME value:
Jul 24, 2008 5:11:50 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
Jul 24, 2008 5:11:50 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: CONFIRMATION ANSWER value:
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: CONFIRMATION ANSWER value: yes
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter LOG_FILE.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter DB_UNIQUE_NAME.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter DB_UNIQUE_NAME.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine connecting with SID: test1, oracleHome: C:\oracle\product\10.2.0\db_1, and user: SYS
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine created successfully and connected
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.DatabaseChecks getDbUniqueName
CONFIG: No Database unique name available. Will try to retrieve it from DB itself
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: DB_UNIQUE_NAME value: test1
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.EMConfig perform
INFO: This operation is being logged at C:\oracle\product\10.2.0\db_1\cfgtoollogs\emca\test1\emca_2008-07-24_05-11-37-PM.log.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setFlag
CONFIG: Flag 'CHECK_CONFIG' set to true
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine connecting with SID: test1, oracleHome: C:\oracle\product\10.2.0\db_1, and user: SYS
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine created successfully and connected
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine connecting with SID: test1, oracleHome: C:\oracle\product\10.2.0\db_1, and user: DBSNMP
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine created successfully and connected
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter MODIFY_SID.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine connecting with SID: test1, oracleHome: C:\oracle\product\10.2.0\db_1, and user: SYS
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine created successfully and connected
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setFlag
CONFIG: Flag 'asm_db' set to false
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter MODIFY_SID.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.DatabaseChecks getDbServiceName
CONFIG: No service name available. Will try to set db_unique_name.db_domain
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine connecting with SID: test1, oracleHome: C:\oracle\product\10.2.0\db_1, and user: SYS
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine created successfully and connected
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: DB_UNIQUE_NAME value:
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter DB_UNIQUE_NAME.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.DatabaseChecks getDbUniqueName
CONFIG: No Database unique name available. Will try to retrieve it from DB itself
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: DB_UNIQUE_NAME value: test1
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter DB_DOMAIN.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.DatabaseChecks getDbDomain
CONFIG: No db domain available. Will query db for db_domain parameter
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: DB_DOMAIN value: world
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: DB_UNIQUE_NAME value: test1
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: SERVICE_NAME value: test1.world
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter MODIFY_SID.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter DBID.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.DatabaseChecks getDbid
CONFIG: No dbid available. Will query db to extract it.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine connecting with SID: test1, oracleHome: C:\oracle\product\10.2.0\db_1, and user: SYS
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine created successfully and connected
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: DBID value: 1037889194
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setFlag
CONFIG: Flag 'db' set to true
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter MODIFY_SID.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.DatabaseChecks getDbServiceName
CONFIG: No service name available. Will try to set db_unique_name.db_domain
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine connecting with SID: test1, oracleHome: C:\oracle\product\10.2.0\db_1, and user: SYS
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine created successfully and connected
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: DB_UNIQUE_NAME value:
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter DB_UNIQUE_NAME.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.DatabaseChecks getDbUniqueName
CONFIG: No Database unique name available. Will try to retrieve it from DB itself
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: DB_UNIQUE_NAME value: test1
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: DB_DOMAIN value: world
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: DB_UNIQUE_NAME value: test1
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: SERVICE_NAME value: test1.world
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter EMAIL_ADDRESS.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter MAIL_SERVER_NAME.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine connecting with SID: test1, oracleHome: C:\oracle\product\10.2.0\db_1, and user: SYS
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine created successfully and connected
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.EMDBPreConfig invoke
CONFIG: Passed repository configuration check
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter MODIFY_SID.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter MODIFY_SID.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter GLOBAL_DB_UNIQUE_NAME.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.DatabaseChecks getGlobalDbUniqueName
CONFIG: No Global database unique name available. Will try to retrieve it from DB itself
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine connecting with SID: test1, oracleHome: C:\oracle\product\10.2.0\db_1, and user: SYS
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine created successfully and connected
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: DB_DOMAIN value: world
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: GLOBAL_DB_UNIQUE_NAME value: test1.world
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.FileUtil _copyFile
CONFIG: Copying file C:\oracle\product\10.2.0\db_1\sysman\config\emd.properties to C:\oracle\product\10.2.0\db_1\sysman\config\emd.properties.emca.tmp
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.FileUtil backupFile
CONFIG: The original file C:\oracle\product\10.2.0\db_1\sysman\config\emd.properties has been copied to C:\oracle\product\10.2.0\db_1\sysman\config\emd.properties.emca.tmp
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.FileUtil _copyFile
CONFIG: Copying file C:\oracle\product\10.2.0\db_1\sysman\config\emoms.properties to C:\oracle\product\10.2.0\db_1\sysman\config\emoms.properties.emca.tmp
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.FileUtil backupFile
CONFIG: The original file C:\oracle\product\10.2.0\db_1\sysman\config\emoms.properties has been copied to C:\oracle\product\10.2.0\db_1\sysman\config\emoms.properties.emca.tmp
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.FileUtil _copyFile
CONFIG: Copying file C:\oracle\product\10.2.0\db_1\sysman\emd\targets.xml to C:\oracle\product\10.2.0\db_1\sysman\emd\targets.xml.emca.tmp
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.FileUtil backupFile
CONFIG: The original file C:\oracle\product\10.2.0\db_1\sysman\emd\targets.xml has been copied to C:\oracle\product\10.2.0\db_1\sysman\emd\targets.xml.emca.tmp
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.ClusterUtil getLocalNode
CONFIG: isLocalNodeDone: true localNode: null
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setFlag
CONFIG: Flag 'IS_CENTRAL_AGENT_RECONFIG' set to false
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.ClusterUtil getLocalNode
CONFIG: isLocalNodeDone: true localNode: null
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.CentralAgentUtil isCentralAgentConfigured
CONFIG: Sid: test1 Host: testblade.microtekmed.com Node: null OH: C:\oracle\product\10.2.0\db_1 agentHome: null isCentral: false
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.DBControlUtil isDBConsoleConfigured
CONFIG: Sid: test1 Host: testblade.microtekmed.com Node: null OH: C:\oracle\product\10.2.0\db_1 isDBC: false
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setFlag
CONFIG: Flag 'IS_CENTRAL_AGENT_CONFIGURED' set to false
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setFlag
CONFIG: Flag 'IS_DBCONTROL_CONFIGURED' set to false
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter DBCONTROL_HTTP_PORT.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter AGENT_PORT.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter RMI_PORT.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter JMS_PORT.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.ClusterUtil getLocalNode
CONFIG: isLocalNodeDone: true localNode: null
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.DBControlUtil isDBConsoleConfigured
CONFIG: Sid: test1 Host: testblade.microtekmed.com Node: null OH: C:\oracle\product\10.2.0\db_1 isDBC: false
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter ORACLE_HOSTNAME.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter PORTS_FILE.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.ClusterUtil getLocalNode
CONFIG: isLocalNodeDone: true localNode: null
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter JMS_PORT_test1.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter JMS_PORT.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter RMI_PORT_test1.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter RMI_PORT.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter DBCONTROL_HTTP_PORT_test1.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter DBCONTROL_HTTP_PORT.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter AGENT_PORT_test1.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter AGENT_PORT.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.OUIInventoryUtil setOUILoc
CONFIG: Setting oracle.installer.oui_loc to C:\oracle\product\10.2.0\db_1\oui
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.OUIInventoryUtil setOUILoc
CONFIG: Setting oracle.installer.oui_loc to C:\oracle\product\10.2.0\db_1\oui
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.PortManager markAllUsedPorts
CONFIG: Homes to scan for used ports: [C:\oracle\product\10.2.0\db_1]
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.PortManager markAllUsedPorts
CONFIG: Searching all DBConsole instances for used ports under ORACLE_HOME C:\oracle\product\10.2.0\db_1
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.PortManager markAllUsedPorts
CONFIG: Marking JMS port: null from C:\oracle\product\10.2.0\db_1\oc4j\j2ee\OC4J_DBConsole
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.PortManager markAllUsedPorts
CONFIG: Marking RMI port: null from C:\oracle\product\10.2.0\db_1\oc4j\j2ee\OC4J_DBConsole
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.PortManager markAllUsedPorts
CONFIG: Marking HTTP port: null from C:\oracle\product\10.2.0\db_1\oc4j\j2ee\OC4J_DBConsole
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.PortManager markAllUsedPorts
CONFIG: Marking Agent port: 5500 from C:\oracle\product\10.2.0\db_1\sysman\config\emd.properties
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.FileUtil getProperties
CONFIG: Error reading file C:\oracle\product\10.2.0\db_1\install\staticports.ini
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.PortManager getFreePorts
CONFIG: C:\oracle\product\10.2.0\db_1:testblade.microtekmed.com:null:test1:{}:null:{DBCONTROL_HTTP_PORT=1158, RMI_PORT=5520, JMS_PORT=5540, AGENT_PORT=3938}
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter AGENT_PORT_test1.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: AGENT_PORT_test1 value: 3938
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter DBCONTROL_HTTP_PORT_test1.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: DBCONTROL_HTTP_PORT_test1 value: 1158
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter JMS_PORT_test1.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: JMS_PORT_test1 value: 5540
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager getParam
CONFIG: No value was set for the parameter RMI_PORT_test1.
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.ParamsManager setParam
CONFIG: Setting param: RMI_PORT_test1 value: 5520
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.EMDBPreConfig getFreePorts
CONFIG: Ports assigned for SID: test1 : {DBCONTROL_HTTP_PORT=1158, RMI_PORT=5520, JMS_PORT=5540, AGENT_PORT=3938}
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine connecting with SID: test1, oracleHome: C:\oracle\product\10.2.0\db_1, and user: SYS
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.util.GeneralUtil initSQLEngine
CONFIG: SQLEngine created successfully and connected
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.EMReposConfig createRepository
CONFIG: Spooling to C:\oracle\product\10.2.0\db_1\cfgtoollogs\emca\test1\emca_repos_create_2008-07-24_05-11-52-PM.log
Jul 24, 2008 5:11:52 PM oracle.sysman.emcp.EMReposConfig createRepository
INFO: Creating the EM repository (this may take a while) ...
Jul 24, 2008 5:11:53 PM oracle.sysman.emcp.EMReposConfig createRepository
CONFIG: ORA-04042: procedure, function, package, or package body does not exist
ORA-06512: at line 11


oracle.sysman.assistants.util.sqlEngine.SQLFatalErrorException: ORA-04042: procedure, function, package, or package body does not exist
ORA-06512: at line 11


at oracle.sysman.assistants.util.sqlEngine.SQLEngine.executeImpl(SQLEngine.java:1467)
at oracle.sysman.assistants.util.sqlEngine.SQLEngine.executeScript(SQLEngine.java:841)
at oracle.sysman.assistants.util.sqlEngine.SQLPlusEngine.executeScript(SQLPlusEngine.java:265)
at oracle.sysman.assistants.util.sqlEngine.SQLPlusEngine.executeScript(SQLPlusEngine.java:306)
at oracle.sysman.emcp.EMReposConfig.createRepository(EMReposConfig.java:360)
at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:182)
at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:124)
at oracle.sysman.emcp.EMConfig.perform(EMConfig.java:142)
at oracle.sysman.emcp.EMConfigAssistant.invokeEMCA(EMConfigAssistant.java:479)
at oracle.sysman.emcp.EMConfigAssistant.performConfiguration(EMConfigAssistant.java:1123)
at oracle.sysman.emcp.EMConfigAssistant.statusMain(EMConfigAssistant.java:463)
at oracle.sysman.emcp.EMConfigAssistant.main(EMConfigAssistant.java:412)
Jul 24, 2008 5:11:53 PM oracle.sysman.emcp.EMReposConfig invoke
SEVERE: Error creating the repository
Jul 24, 2008 5:11:53 PM oracle.sysman.emcp.EMReposConfig invoke
INFO: Refer to the log file at C:\oracle\product\10.2.0\db_1\cfgtoollogs\emca\test1\emca_repos_create_<date>.log for more details.
Jul 24, 2008 5:11:53 PM oracle.sysman.emcp.EMConfig perform
SEVERE: Error creating the repository

Refer to the log file at C:\oracle\product\10.2.0\db_1\cfgtoollogs\emca\test1\emca_2008-07-24_05-11-37-PM.log for more details.
Jul 24, 2008 5:11:53 PM oracle.sysman.emcp.EMConfig perform
CONFIG: Stack Trace:
oracle.sysman.emcp.exception.EMConfigException: Error creating the repository
at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:194)
at oracle.sysman.emcp.EMReposConfig.invoke(EMReposConfig.java:124)
at oracle.sysman.emcp.EMConfig.perform(EMConfig.java:142)
at oracle.sysman.emcp.EMConfigAssistant.invokeEMCA(EMConfigAssistant.java:479)
at oracle.sysman.emcp.EMConfigAssistant.performConfiguration(EMConfigAssistant.java:1123)
at oracle.sysman.emcp.EMConfigAssistant.statusMain(EMConfigAssistant.java:463)
at oracle.sysman.emcp.EMConfigAssistant.main(EMConfigAssistant.java:412)

[Updated on: Fri, 25 July 2008 09:13]

Report message to a moderator

Re: Manual OEM install issue - [message #336312 is a reply to message #336280] Fri, 25 July 2008 11:02 Go to previous messageGo to next message
sbaker
Messages: 12
Registered: April 2006
Junior Member
Fixed it, thanks for just viewing my issue with little response....

For those that follow with the issue here is how I fixed it.


> @$ORACLE_HOME/rdbms/admin/dbmspool.sql
Package created.
3. Create the dbmspool package body:

SQL> @$ORACLE_HOME/rdbms/admin/prvtpool.plb
View created.
Package body created.
4. Grant execution privilege on the package:

SQL> grant execute on dbms_shared_pool to sysman;
Grant succeeded.
SQL> grant execute on dbms_shared_pool to dba;
Grant succeeded.
Re: Manual OEM install issue - [message #336319 is a reply to message #336280] Fri, 25 July 2008 11:24 Go to previous messageGo to next message
BlackSwan
Messages: 25042
Registered: January 2009
Location: SoCal
Senior Member
THANKS for posting the solution!
Re: Manual OEM install issue - [message #336324 is a reply to message #336312] Fri, 25 July 2008 12:20 Go to previous message
sbaker
Messages: 12
Registered: April 2006
Junior Member
I'm more than happy to help out where and when I can Smile
Previous Topic: Automated Backups -Unable to perform the backup because the database is closed.
Next Topic: Metric Critical Alert - should I care?
Goto Forum:
  


Current Time: Wed Dec 07 07:06:40 CST 2016

Total time taken to generate the page: 0.32496 seconds