Home » Developer & Programmer » Forms » Same built-in procedures working in menus but non functional in toolbar buttons. (form 6i, XP)
Same built-in procedures working in menus but non functional in toolbar buttons. [message #335753] Wed, 23 July 2008 09:55 Go to next message
ms.bushra
Messages: 2
Registered: July 2008
Location: Islamabad
Junior Member
I have a tabbed canvas having different data block under each tab. The built in procedures to insert,update, delete etc are working well in menu items but some of them, when called through toolbar button do not work.

Like when I press the button to insert record the message shown is ,"Record must be entered or deleted first". I am calling the built-in procedure CREATE_RECORD.

Similarly when I navigate to the record to be deleted and then press the delete button nothing happens and when I click the Save button the message is displayed as, "No changes to save".I am using DELETE_RECORD procedure here.

Many thanks are for your help.
Re: Same built-in procedures working in menus but non functional in toolbar buttons. [message #336141 is a reply to message #335753] Fri, 25 July 2008 00:34 Go to previous message
gurupatham
Messages: 66
Registered: March 2008
Location: Chennai
Member
when you use Create_record without value in block "Record must be entered or deleted first" Error message will be displayed.


when you save the record by using commit_form after delete the record by using delete_record , definitely "Transaction complete: 1 record applied ans saved" message will be displayed . and record gets saved in database.

I think here you have done some other mistake . check it..
Previous Topic: Developer Suite Installation issue
Next Topic: Web.Show_Document - Authentication
Goto Forum:
  


Current Time: Thu Dec 08 08:40:08 CST 2016

Total time taken to generate the page: 0.14961 seconds