Home » Developer & Programmer » Forms » Using Webutil, can not use Client_ole2 (Oracle AS/DS
Using Webutil, can not use Client_ole2 [message #333373] Fri, 11 July 2008 07:27 Go to next message
Messages: 18
Registered: May 2008
Junior Member
Hi everybody!

I have worked 2 days try to solve this problem, but failed.

I've installed Oracle AS in the server, and Oracle DS&AS installed in the test machine. All these versions are 10g (

My code using client_ole2 in webutil to create and save a .xls file to the client. This code running good in test machine, and I deploy the code to Oracle AS in test machine, it also fine, the .xls file was created in the client.

But when I deployed the code to Server machine, It doesn't work. And I download the Oracle Webutil demo form(WU_TEST_106.fmb) web and deployed to the Server. It works fine except OLE. The error code is:

java.lang.ExceptionInInitializerError: java.security.AccessControlException: access denied (java.lang.RuntimePermission loadLibrary.jacob)

and somthing like that.

So it is the question, why webutil works fine except OLE?

1. I didn't install the MS EXCEL in the server but installed in the test machine. Need I install EXCEL in the server?

2. The jacob.jar file might not signed in the server, because I didn't find the sign_webutil.bat file in path <Oracle AS Home>\forms\webutil or any other path. So I've no idea how to sign it. By the way, in test machine, I use sign_webutil.bat in DS derectory to sign jacob.jar both in DS path and AS path.

Thank you verry much!

[Updated on: Fri, 11 July 2008 07:34]

Report message to a moderator

Re: Using Webutil, can not use Client_ole2 [message #333440 is a reply to message #333373] Fri, 11 July 2008 11:53 Go to previous message
Messages: 18
Registered: May 2008
Junior Member
I think I had solved this problem. That's because I didn't sign jacob.jar. MS Office is no need to install.

I just remind that in a Chinese forum, somebody said that he not successed configuring webutil, but when he download a webutil 1.06 and overwrite the origional file and then he successed.

So, I download webutil 1.06, and then copy out the sign_webutil.bat to the server, then Edit the bat file, add the path of keytool and jarsigner, and then sign the jacob.jar.

And then it works.

Very Happy
Previous Topic: how to use array variable
Next Topic: tabuler recoreds
Goto Forum:

Current Time: Fri Oct 28 09:41:18 CDT 2016

Total time taken to generate the page: 0.08989 seconds