Home » RDBMS Server » Backup & Recovery » RMAN backup failing. (Oracle 10g, Linux Redhat.)
RMAN backup failing. [message #333218] Thu, 10 July 2008 20:38 Go to next message
geeklol
Messages: 59
Registered: March 2005
Member
i am getting the following error, when trying to run RMAN backup on Oracle 10g database using netbackup. please help!

The backup runs for about an hour or so and from what my netbackup admin tells me, it backs up about 150 gb of the total 270 gb and then it fails giving me the following error.

please help, i am going live with this system on saturday and the backups have to work.

Recovery Manager: Release 10.2.0.1.0 - Production on Thu Jul 10 15:39:36 2008

Copyright (c) 1982, 2005, Oracle. All rights reserved.

RMAN> #der: lcecdb_backup_level0.rcv,v 1.5 2004/10/21 21:40:06 integ Exp $
2> # ---------------------------------------------------------------------------
3> # lcecdb_backup_level0.rcv
4> # ---------------------------------------------------------------------------
5> # Script run by:
6> # rman nocatalog cmdfile lcecdb_backup_level0.rcv
7> # ---------------------------------------------------------------------------
8>
9> connect target
10> connect catalog *
11>
12> ###set snapshot controlfile name to '/home/archive/DBA/backup_to_tape/48009/snapcf_lcecdb.f'
13> set snapshot controlfile name to '/home/oracle/nbscripts/DBA/snapcf_lcecdb.f'
14>
15> run {
16> # Hot database level 0 whole backup
17> allocate channel t1 type 'SBT_TAPE';
18> backup
19> incremental level 0
20> skip inaccessible
21> # recommended format
22> format 'bk_%s_%p_%t'
23> database
24> filesperset = 500;
25> sql 'alter system archive log current';
26> release channel t1;
27>
28> allocate channel t1 type 'SBT_TAPE';
29> backup
30> format 'cntrl_%s_%p_%t'
31> current controlfile;
32> release channel t1;
33> }
34>
connected to target database: LCECDB (DBID=4204144680)

connected to recovery catalog database

executing command: SET SNAPSHOT
snapshot control file name set to: /home/oracle/nbscripts/DBA/snapcf_lcecdb.f
new RMAN configuration parameters are successfully stored

allocated channel: t1
channel t1: sid=1077 devtype=SBT_TAPE
channel t1: Veritas NetBackup for Oracle - Release 6.5 (2007072323)

Starting backup at 10-JUL-08
channel t1: starting incremental level 0 datafile backupset
channel t1: specifying datafile(s) in backupset
input datafile fno=00156 name=/db02/oradata/lcecdb/data/lcec_tbl_users_del_gj_10m_01.dbf
<<THERE ARE MORE DATAFILES HERE, but to keep the forum short, i am deleting the rest of the datafiles>>
input datafile fno=00168 name=/db02/oradata/lcecdb/data/indx01.dbf
channel t1: starting piece 1 at 10-JUL-08
RMAN-03009: failure of backup command on t1 channel at 07/10/2008 16:54:33
ORA-19513: failed to identify sequential file
ORA-27206: requested file not found in media management catalog
continuing other job steps, job failed will not be re-run
channel t1: starting incremental level 0 datafile backupset
channel t1: specifying datafile(s) in backupset
including current control file in backupset
channel t1: starting piece 1 at 10-JUL-08
released channel: t1
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of backup command on t1 channel at 07/10/2008 16:55:19
ORA-19513: failed to identify sequential file
ORA-27206: requested file not found in media management catalog

Recovery Manager complete.

Thu Jul 10 16:55:21 PDT 2008 ----------------End of Script------------------
Re: RMAN backup failing. [message #333222 is a reply to message #333218] Thu, 10 July 2008 22:21 Go to previous messageGo to next message
geeklol
Messages: 59
Registered: March 2005
Member
FYI, this is my first time backing up this database. i have registered it in the catalog.

Does the error, ORA-19513, sequencial file not found error mean that it is looking for a previous sequence of the datafiles etc and it cannot find it and hance it is failing?

Please help. thank you!
Re: RMAN backup failing. [message #333263 is a reply to message #333222] Fri, 11 July 2008 01:17 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
>>ORA-27206: requested file not found in media management catalog
This has nothing to do with RMAN.
Some configuration in netbackup is not correct. I would particularly check for Client_Name.

Re: RMAN backup failing. [message #333458 is a reply to message #333218] Fri, 11 July 2008 13:26 Go to previous messageGo to next message
geeklol
Messages: 59
Registered: March 2005
Member
Hi Mahesh,

thank you.

For some reason, it still backs up ONLY 150 GB and not the complete 260 GB database.

I changed my script from filesperset 500 to filesperset 40, which should make it a smaller backupset.

But is there a LIMIT either on netbackup or within oracle or RMAN, that limits the size of the backup to 150 GB ? how do i find out about that in ORACLE ?

Thank you!

RMAN> run {
allocate channel t1 type 'SBT_TAPE';
send 'NB_ORA_SERV=laxas4bkp01, NB_ORA_CLIENT=laxas4odb01';
backup
incremental level 0
skip inaccessible
format 'bk_%s_%p_%t'
database
filesperset 500;
sql 'alter system archive log current';
release channel t1;
}
Re: RMAN backup failing. [message #333460 is a reply to message #333458] Fri, 11 July 2008 13:32 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
>>filesperset 40, which should make it a smaller backupset.
Not essentially.
You limited only the number of files. Not the size of individual backuppiece.

>>For some reason, it still backs up ONLY 150 GB and not the complete 260 GB database.
Post the exact log.
Again, if it is the same error, did you check your netbackup configs?
Re: RMAN backup failing. [message #333481 is a reply to message #333218] Fri, 11 July 2008 18:34 Go to previous messageGo to next message
geeklol
Messages: 59
Registered: March 2005
Member
the error that i am getting is as below:

but when my netbackup admin is monitoring the netbackup, it backs up upto 150gb and after that it fails.

there are other backups on the same tape library, which are larger than 200 gb and they all backup fine. it is just this one that fails at 150gb.

would u recommend i restrict the size of inidvidual backup piece? if so how do i do it? i am running out of time, please help. thank you!!

channel t1: starting piece 1 at 11-JUL-08
RMAN-03009: failure of backup command on t1 channel at 07/11/2008 15:46:06
ORA-19513: failed to identify sequential file
ORA-27206: requested file not found in media management catalog
continuing other job steps, job failed will not be re-run
channel t1: starting incremental level 0 datafile backupset
channel t1: specifying datafile(s) in backupset
including current control file in backupset
channel t1: starting piece 1 at 11-JUL-08
released channel: t1
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of backup command on t1 channel at 07/11/2008 15:46:51
ORA-19513: failed to identify sequential file
ORA-27206: requested file not found in media management catalog

Recovery Manager complete.
Re: RMAN backup failing. [message #333482 is a reply to message #333481] Fri, 11 July 2008 19:05 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
As Mahesh has already indicated, I would suspect it's a Netbackup configuration issue. May want to check the netbackup logs and also verify that the netbackup client was linked properly. Has this ever worked on this node/database?

In answer to your other question, you can limit the size by specifying MAXPIECESIZE.
Re: RMAN backup failing. [message #333483 is a reply to message #333218] Fri, 11 July 2008 19:10 Go to previous messageGo to next message
geeklol
Messages: 59
Registered: March 2005
Member
hi ebrian, Mahesh,

backup has never worked on this node before.

netbackup client is definately linked to the oracle library properly.

if i change the MAXPIECESIZE setting to as follows, u think it may help?
RMAN> CONFIGURE CHANNEL DEVICE TYPE DISK MAXPIECESIZE = 100G;

when i run the backup manually from RMAN command line, i get the following error instead of the other one,
====

input datafile fno=00168 name=/db02/oradata/lcecdb/data/indx01.dbf
channel t1: starting piece 1 at 11-JUL-08
released channel: t1
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of backup command on t1 channel at 07/11/2008 17:03:34
ORA-27192: skgfcls: sbtclose2 returned error - failed to close file
ORA-19511: Error received from media manager layer, error text:
Failed to process backup file <bk_38_1_659809037>
ORA-19502: write error on file "bk_38_1_659809037", blockno 176922113 (blocksize=512)
ORA-27030: skgfwrt: sbtwrite2 returned error
ORA-19511: Error received from media manager layer, error text:
VxBSASendData: Failed with error:
Re: RMAN backup failing. [message #333484 is a reply to message #333218] Fri, 11 July 2008 19:15 Go to previous messageGo to next message
geeklol
Messages: 59
Registered: March 2005
Member
hi again,

it there was a problem with the netbackup configuration, how would it even write 150gb? shouldn't it just fail right away? is there any limit in oracle that i should be aware of that probably kills the backup after 150 gb?

thank you!
Re: RMAN backup failing. [message #333491 is a reply to message #333484] Fri, 11 July 2008 22:25 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
There appears to be a similar bug 7191856 for this same issue albeit on Win2k3 with NetBackup. You may want to file an SR with Oracle.

Please keep us informed.
Re: RMAN backup failing. [message #333623 is a reply to message #333218] Sun, 13 July 2008 12:14 Go to previous messageGo to next message
geeklol
Messages: 59
Registered: March 2005
Member
Hi all,

thanks for all your help.

still the same issue. will keep you all posted once i get this resolved. for right now, i am backing up the db to disk and then from there am backing it up to tape.

i have opened a TAR with oracle as well.

ebrian,
when i googled, bug 7191856, i am not able to find any entries except our forum-conversation. where should i look for this bug? which site?

thank you!
Re: RMAN backup failing. [message #333624 is a reply to message #333218] Sun, 13 July 2008 12:42 Go to previous message
BlackSwan
Messages: 25036
Registered: January 2009
Location: SoCal
Senior Member
>where should i look for this bug?
http://metalink.oracle.com
Previous Topic: ORA-01547: warning: RECOVER succeeded but OPEN RESETLOGS required....
Next Topic: Creating Clone database manually
Goto Forum:
  


Current Time: Sun Dec 04 04:27:54 CST 2016

Total time taken to generate the page: 0.04195 seconds