Home » RDBMS Server » Backup & Recovery » How to disable sbt_tape in recovery process (ver:10.1.0.1.0 . OS winxp sp2,)
How to disable sbt_tape in recovery process [message #332399] Tue, 08 July 2008 07:56 Go to next message
malikjee
Messages: 80
Registered: May 2007
Location: lahore
Member

Hi all!
Information about database:

ver:10.1.0.1.0 . OS winxp sp2,

My database is in archivelog mode and flashback is also on.AND can be changed in all status like mount or open on sqlplus shell command prompt.backup command suceeded but recover or restore type commands fails with error
Today I faced a trouble when I tried to restore a table from my backup which is kept in flash_recovery_area at my database server computer.I connected as sysdba on my database server
My database is in mount stat not open for use.
My database is configured with dbconsole and is started sucessfully.
one day before,I had configured my database with device type SBT_TAPE mistakenly. via 'configure recovery setting' option in my dbconsole 'PERFORM RECOVERY' home screen.
Now whenever I try to recover or restore the database's any object from recover area then it gives an error as foloows.
please tell me any sound command from which I can de configure RMAN so that at recovery time RMAN should use only device type disk option and not sbt device etc.
My detailed SQL*PLUS on shell command prompt is as follows.

SQL> show parameters  db_recover_file_dest;
SQL> show parameters  db_recovery_file_dest;

NAME                                 TYPE        VALUE
------------------------------------ ----------- ------------------------------
db_recovery_file_dest                string      D:\flash_recovery_area
db_recovery_file_dest_size           big integer 2500M
SQL> conn /as sysdba;
Connected.
SQL> ho rman target/

Recovery Manager: Release 10.1.0.2.0 - Production

Copyright (c) 1995, 2004, Oracle.  All rights reserved.

connected to target database: A (DBID=3893898385)

RMAN> restore tablespace users;

Starting restore at 30-JUN-08
using target database controlfile instead of recovery catalog
allocated channel: ORA_DISK_1
channel ORA_DISK_1: sid=136 devtype=DISK
allocated channel: ORA_DISK_2
channel ORA_DISK_2: sid=135 devtype=DISK
released channel: ORA_DISK_1
released channel: ORA_DISK_2
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of restore command at 06/30/2008 13:56:46
ORA-19554: error allocating device, device type: SBT_TAPE, device name:
ORA-27211: Failed to load Media Management Library

RMAN> backup tablespace users;

Starting backup at 30-JUN-08
allocated channel: ORA_DISK_1
channel ORA_DISK_1: sid=136 devtype=DISK
allocated channel: ORA_DISK_2
channel ORA_DISK_2: sid=135 devtype=DISK
channel ORA_DISK_1: starting compressed full datafile backupset
channel ORA_DISK_1: specifying datafile(s) in backupset
input datafile fno=00004 name=E:\ORACLE\PRODUCT\10.1.0\ORADATA\A\USERS01.DBF
channel ORA_DISK_1: starting piece 1 at 30-JUN-08
channel ORA_DISK_1: finished piece 1 at 30-JUN-08
piece handle=D:\FLASH_RECOVERY_AREA\A\BACKUPSET\2008_06_30\O1_MF_NNNDF_TAG20080630T
6K7Z575_.BKP comment=NONE
channel ORA_DISK_1: backup set complete, elapsed time: 00:00:07
Finished backup at 30-JUN-08

Starting Control File and SPFILE Autobackup at 30-JUN-08
piece handle=D:\FLASH_RECOVERY_AREA\A\AUTOBACKUP\2008_06_30\O1_MF_S_658763836_46K7Z
 comment=NONE
Finished Control File and SPFILE Autobackup at 30-JUN-08

RMAN> exit


Recovery Manager complete.

SQL> ho rman target/

Recovery Manager: Release 10.1.0.2.0 - Production

Copyright (c) 1995, 2004, Oracle.  All rights reserved.

connected to target database: A (DBID=3893898385)

RMAN> show all;

using target database controlfile instead of recovery catalog
RMAN configuration parameters are:
CONFIGURE RETENTION POLICY TO RECOVERY WINDOW OF 7 DAYS;
CONFIGURE BACKUP OPTIMIZATION ON;
CONFIGURE DEFAULT DEVICE TYPE TO DISK; # default
CONFIGURE CONTROLFILE AUTOBACKUP ON;
CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE DISK TO '%F'; # default
CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE SBT_TAPE TO '%F'; # default
CONFIGURE DEVICE TYPE DISK BACKUP TYPE TO COMPRESSED BACKUPSET PARALLELISM 2;
CONFIGURE DEVICE TYPE SBT_TAPE PARALLELISM 1 BACKUP TYPE TO BACKUPSET; # default
CONFIGURE DATAFILE BACKUP COPIES FOR DEVICE TYPE DISK TO 1; # default
CONFIGURE DATAFILE BACKUP COPIES FOR DEVICE TYPE SBT_TAPE TO 1; # default
CONFIGURE ARCHIVELOG BACKUP COPIES FOR DEVICE TYPE DISK TO 1; # default
CONFIGURE ARCHIVELOG BACKUP COPIES FOR DEVICE TYPE SBT_TAPE TO 1; # default
CONFIGURE CHANNEL DEVICE TYPE DISK MAXPIECESIZE 2 G;
CONFIGURE CHANNEL DEVICE TYPE 'SBT_TAPE' MAXPIECESIZE 2 G;
CONFIGURE MAXSETSIZE TO UNLIMITED; # default
CONFIGURE ARCHIVELOG DELETION POLICY TO NONE; # default
CONFIGURE SNAPSHOT CONTROLFILE NAME TO 'E:\ORACLE\PRODUCT\10.1.0\DB_1\DATABASE\SNCFA.ORA';
# default

RMAN>

Any suggession will be highly appreciated.

Best reagards,
Malik
Re: How to disable sbt_tape in recovery process [message #332402 is a reply to message #332399] Tue, 08 July 2008 08:08 Go to previous messageGo to next message
Michel Cadot
Messages: 64152
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
http://www.orafaq.com/forum/?SQ=cf29f386f995dea25a32d5837fc128e3&t=search&srch=sbt_tape&btn_submit=Search&field=all&a mp;forum_limiter=&search_logic=AND&sort_order=DESC&author=

Regards
Michel
Re: How to disable sbt_tape in recovery process [message #332607 is a reply to message #332399] Wed, 09 July 2008 02:59 Go to previous message
malikjee
Messages: 80
Registered: May 2007
Location: lahore
Member

Hi all
Thanks Mr Michel for your proper and timely guidance.

My issue was solved regarding above query.

Best regards,
Malik
Previous Topic: ORA-00054: resource busy and acquire with NOWAIT specified
Next Topic: RMAN backup
Goto Forum:
  


Current Time: Sat Dec 10 06:51:23 CST 2016

Total time taken to generate the page: 0.07750 seconds