Home » RDBMS Server » Server Utilities » ORA-00439 (Database version 9.0.1.00)
ORA-00439 [message #330578] Mon, 30 June 2008 09:09 Go to next message
dillango
Messages: 145
Registered: January 2008
Senior Member
Dear All,

I have problem while importing the dump file.
I have exported the dump file from the Server for a particular user and the same I tried to import in my personal computer.

while I importing, I am getting an error "0RA-00439 Feature not enabled: Materialized view rewrite"
However, I could see all the tables, procedures, functions perfectly imported with all the rows.

Note: I am using the same version for both Server and my personal system. Tablespace name, datafile name, user name also same like Server.

Is there anything I have to concentrate while exporting the tables to overcome this problem?
Please have your suggestion.

ILANGO
Re: ORA-00439 [message #330580 is a reply to message #330578] Mon, 30 June 2008 09:15 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
I would check the initsid.ora or spfile parameter between the databases.
http://youngcow.net/doc/oracle9i/server.920/a96536/ch1169.htm

Re: ORA-00439 [message #330588 is a reply to message #330580] Mon, 30 June 2008 09:28 Go to previous messageGo to next message
dillango
Messages: 145
Registered: January 2008
Senior Member
Mr.Mahesh,

Thanks for your quick response.

I did not find the file as initsid.ora. However, I have the file init.ora. This file is from my local system. I am attaching this for your reference.

Right now I am at home and the server file I will send you tomorrow.

ILANGO
  • Attachment: init.ora
    (Size: 2.50KB, Downloaded 137 times)
Re: ORA-00439 [message #330590 is a reply to message #330588] Mon, 30 June 2008 09:33 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
>>I did not find the file as initsid.ora.
What i meant is, init< yourSID >.ora
You can manually check the file
or
query the existing values from sqlplus.
Check if these are set in your 'personal' database and 'other' database.
dbadmin@xxx > show parameter query_rewrite

NAME                                 TYPE        VALUE
------------------------------------ ----------- ------------------------------
query_rewrite_enabled                string      true
query_rewrite_integrity              string      trusted

[Updated on: Mon, 30 June 2008 09:35]

Report message to a moderator

Re: ORA-00439 [message #330594 is a reply to message #330590] Mon, 30 June 2008 09:44 Go to previous messageGo to next message
dillango
Messages: 145
Registered: January 2008
Senior Member
Mr.Mahesh,

Sorry, I am not technically so strong in DBA.

My SID is walaa.
The content of my file have only one line as
ifile='d:\oracle\admin\walaa\pfile\init.ora'

I have alredy attached the init.ora file.

Secondly, I have attached the result of my "show parameter query_rewrite"


Regards,
ILANGO
  • Attachment: query.JPG
    (Size: 55.09KB, Downloaded 119 times)
Re: ORA-00439 [message #330598 is a reply to message #330594] Mon, 30 June 2008 09:49 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
In future, if possible, please post the output here (copy and paste) instead of attaching every other response.
It seems that the parameter is set to false.

Quote:

NAME                                 TYPE        VALUE
------------------------------------ ----------- ------------------------------
query_rewrite_enabled                string      false



set the parameter to true, bounce the database and try again.

[Updated on: Mon, 30 June 2008 09:53]

Report message to a moderator

Re: ORA-00439 [message #330606 is a reply to message #330598] Mon, 30 June 2008 09:59 Go to previous messageGo to next message
dillango
Messages: 145
Registered: January 2008
Senior Member
Sorry Mr.Mahesh,

I tried to paste but it was not proper (may be I don't know how to do it) that is why I attached the file.

How to set the paramert to True? change the init.ora file?

Regards,
ILANGO
Re: ORA-00439 [message #330611 is a reply to message #330578] Mon, 30 June 2008 10:13 Go to previous messageGo to next message
Michel Cadot
Messages: 64110
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Query rewrite is not available in Standard Edition.
Which Edition have you?

Regards
Michel

Re: ORA-00439 [message #330612 is a reply to message #330606] Mon, 30 June 2008 10:15 Go to previous message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
Yes.
Edit file d:\oracle\admin\walaa\pfile\init.ora
Add entry query_rewrite_enabled=true
Restart the database.
Try again.

PS:
Next time, search before asking.
These questions are asked and answered many many times.
Search this forum/google.
And I do not prefer to be addressed as Mr.Mahesh. Smile
Please replace('Mr.Mahesh','Mr.')

[Updated on: Mon, 30 June 2008 10:20]

Report message to a moderator

Previous Topic: how to overwrite the table name
Next Topic: SQLLDR - Delimited by NEWLINE
Goto Forum:
  


Current Time: Mon Dec 05 11:01:38 CST 2016

Total time taken to generate the page: 0.20716 seconds