Home » Developer & Programmer » Forms » Web_util Help (Oracle Forms 10.1.0.2)
Web_util Help [message #330354] Sun, 29 June 2008 19:00 Go to next message
jpalinski
Messages: 1
Registered: June 2008
Location: Omaha
Junior Member
I have been trying to get a Web_util command to work for days. Everytime I call the function or procedure, I get the following message:

"Ora-06508:PL/SQL: could not find program unit being called Ora-24309: already connected to a server"

When in Forms Builder , the form compiles as well as the function or procedure, but when I display it in the Web browser I get the error. I've tried setting the parameters in the config files, but no luck. I have tried 3 or 4 different procedures and I followed the examples. Not luck. Here is my code:

declare
x varchar2(100);
begin
WebUtil_Host.host('NOTEPAD '||'C:\Test.txt');
exception
when others then message (sqlerrm);
end;

It can't be this hard. Is it having problems finding the library.

Any help would be greatly appreciated.

John
Re: Web_util Help [message #330674 is a reply to message #330354] Mon, 30 June 2008 14:33 Go to previous messageGo to next message
mandeepmandy
Messages: 79
Registered: May 2008
Location: USA
Member

Did you create webutil schema on database.Follow the instuction to crate that the generate webutil.plx from webutil.pll using frmcmp
Re: Web_util Help [message #337192 is a reply to message #330354] Wed, 30 July 2008 02:27 Go to previous message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Have you solved your problem?

David
Previous Topic: Insert/Update by Oracle form
Next Topic: Vertical and Horizontal Scroll Bar for a block
Goto Forum:
  


Current Time: Tue Dec 06 08:41:36 CST 2016

Total time taken to generate the page: 0.16641 seconds