Home » RDBMS Server » Backup & Recovery » set sbt_tape to none? (10.2.0.1.0)
set sbt_tape to none? [message #328248] Thu, 19 June 2008 08:45 Go to next message
JackyShu
Messages: 25
Registered: May 2008
Junior Member
this a question that has been puzzling me for long time, although i can allocate channel manually as a workaround.
scenario: i don't have tape on my desktop, so i want to avoid tape device without put RMAN commands in RUN block (too many typing Mad ).

RMAN> show default device type;

RMAN configuration parameters are:
CONFIGURE DEFAULT DEVICE TYPE TO DISK;

RMAN> show device type;

RMAN configuration parameters are:
CONFIGURE DEVICE TYPE DISK BACKUP TYPE TO COMPRESSED BACKUPSET PARALLELISM 1;
CONFIGURE DEVICE TYPE SBT_TAPE PARALLELISM 1 BACKUP TYPE TO BACKUPSET; # default


RMAN> crosscheck backup;

allocated channel: ORA_DISK_1
channel ORA_DISK_1: sid=142 devtype=DISK
released channel: ORA_DISK_1
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of crosscheck command at 06/19/2008 09:35:25
ORA-19554: error allocating device, device type: SBT_TAPE, device name:
ORA-27211: Failed to load Media Management Library



The crosscheck went to tape after it checked disk. I tried to CLEAR-ed device tape from configure, but as you see it was default, it didn't change anything.

RMAN> configure device type sbt_tape clear;

RMAN configuration parameters are successfully reset to default value

RMAN> crosscheck backup;

allocated channel: ORA_DISK_1
channel ORA_DISK_1: sid=142 devtype=DISK
released channel: ORA_DISK_1
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of crosscheck command at 06/19/2008 09:35:52
ORA-19554: error allocating device, device type: SBT_TAPE, device name:
ORA-27211: Failed to load Media Management Library

RMAN>

any ways to make sbt_tape disappear?
Re: set sbt_tape to none? [message #328266 is a reply to message #328248] Thu, 19 June 2008 10:06 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
I would try
rman>show all;

There might be more one persistent configuration using SBT_TAPE.
If so, clear all them.
Re: set sbt_tape to none? [message #328275 is a reply to message #328248] Thu, 19 June 2008 10:21 Go to previous messageGo to next message
JackyShu
Messages: 25
Registered: May 2008
Junior Member
those are all default values Sad, won't change after CLEAR
RMAN> show all;

RMAN configuration parameters are:
CONFIGURE RETENTION POLICY TO RECOVERY WINDOW OF 14 DAYS;
CONFIGURE BACKUP OPTIMIZATION ON;
CONFIGURE DEFAULT DEVICE TYPE TO DISK;
CONFIGURE CONTROLFILE AUTOBACKUP ON;
CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE DISK TO '%F'; # default
CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE SBT_TAPE TO '%F'; # defa
ult
CONFIGURE DEVICE TYPE DISK BACKUP TYPE TO COMPRESSED BACKUPSET PARALLELISM 1;
CONFIGURE DEVICE TYPE SBT_TAPE PARALLELISM 1 BACKUP TYPE TO BACKUPSET; # default

CONFIGURE DATAFILE BACKUP COPIES FOR DEVICE TYPE DISK TO 1; # default
CONFIGURE DATAFILE BACKUP COPIES FOR DEVICE TYPE SBT_TAPE TO 1; # default
CONFIGURE ARCHIVELOG BACKUP COPIES FOR DEVICE TYPE DISK TO 1; # default
CONFIGURE ARCHIVELOG BACKUP COPIES FOR DEVICE TYPE SBT_TAPE TO 1; # default
CONFIGURE CHANNEL DEVICE TYPE DISK FORMAT   'c:\oracle\backup\%U' MAXPIECESIZE 1
00 M;
CONFIGURE CHANNEL DEVICE TYPE 'SBT_TAPE' MAXPIECESIZE 100 M;
CONFIGURE MAXSETSIZE TO UNLIMITED; # default
CONFIGURE ENCRYPTION FOR DATABASE OFF; # default
CONFIGURE ENCRYPTION ALGORITHM 'AES128'; # default
CONFIGURE ARCHIVELOG DELETION POLICY TO NONE; # default
CONFIGURE SNAPSHOT CONTROLFILE NAME TO 'C:\ORACLE\PRODUCT\10.2.0\DB_1\DATABASE\S
NCFABC.ORA'; # default
Re: set sbt_tape to none? [message #328288 is a reply to message #328275] Thu, 19 June 2008 10:51 Go to previous messageGo to next message
Michel Cadot
Messages: 64152
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Quote:
won't change after CLEAR

I see nothing that clear in what you posted.
Are you sure you did it the correct way?

Regards
Michel
Re: set sbt_tape to none? [message #328289 is a reply to message #328275] Thu, 19 June 2008 10:53 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10672
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
From your output.
>>CONFIGURE CHANNEL DEVICE TYPE 'SBT_TAPE' MAXPIECESIZE 100 M;

As said before,
there are several settings still using SBT_TAPE.
You need to clear them INDIVIDUALLY.
Something like this.
RMAN> CONFIGURE CHANNEL DEVICE TYPE 'SBT_TAPE' MAXPIECESIZE 100 M;

new RMAN configuration parameters:
CONFIGURE CHANNEL DEVICE TYPE 'SBT_TAPE' MAXPIECESIZE 100 M;
new RMAN configuration parameters are successfully stored
starting full resync of recovery catalog
full resync complete

-- just removed the unwanted output.
RMAN> show all;

RMAN configuration parameters are:
....
CONFIGURE CHANNEL DEVICE TYPE 'SBT_TAPE' MAXPIECESIZE 100 M;
....
RMAN> configure device type sbt_tape clear;

RMAN configuration parameters are successfully reset to default value


-- No changes
RMAN>  show all;

RMAN configuration parameters are:
....
CONFIGURE CHANNEL DEVICE TYPE 'SBT_TAPE' MAXPIECESIZE 100 M;
....

RMAN> configure CHANNEL DEVICE TYPE 'SBT_TAPE' clear;

old RMAN configuration parameters:
CONFIGURE CHANNEL DEVICE TYPE 'SBT_TAPE' MAXPIECESIZE 100 M;
old RMAN configuration parameters are successfully deleted
starting full resync of recovery catalog
full resync complete


-- setting is cleared.
RMAN> show all;
RMAN configuration parameters are:
CONFIGURE RETENTION POLICY TO REDUNDANCY 1; # default
CONFIGURE BACKUP OPTIMIZATION OFF; # default
CONFIGURE DEFAULT DEVICE TYPE TO DISK; # default
CONFIGURE CONTROLFILE AUTOBACKUP OFF; # default
CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE DISK TO '%F'; # default
CONFIGURE DEVICE TYPE DISK PARALLELISM 1 BACKUP TYPE TO BACKUPSET; # default
CONFIGURE DATAFILE BACKUP COPIES FOR DEVICE TYPE DISK TO 1; # default
CONFIGURE ARCHIVELOG BACKUP COPIES FOR DEVICE TYPE DISK TO 1; # default
CONFIGURE MAXSETSIZE TO UNLIMITED; # default
CONFIGURE ENCRYPTION FOR DATABASE OFF; # default
CONFIGURE ENCRYPTION ALGORITHM 'AES128'; # default
CONFIGURE ARCHIVELOG DELETION POLICY TO NONE; # default
CONFIGURE SNAPSHOT CONTROLFILE NAME TO '/u01/10g/dbs/snapcf_lawson1.f'; # default
Re: set sbt_tape to none? [message #328291 is a reply to message #328248] Thu, 19 June 2008 11:06 Go to previous message
JackyShu
Messages: 25
Registered: May 2008
Junior Member
Thanks Mahesh, that works. I must have set MAXPIECESIZE for tape and I forgot it.

Michel, there were several settings for sbt_tape, as you can see, only MAXPIECESIZE is non default. I CLEAR-ed those default values, of course nothing happened. They all disappeared once MAXPIECESIZe was cleared.

Previous Topic: How to make tag name unique everytime you run backup script
Next Topic: RMAN BACKUP
Goto Forum:
  


Current Time: Sat Dec 10 03:12:15 CST 2016

Total time taken to generate the page: 0.09393 seconds