Home » Developer & Programmer » Forms » Form hangs (10g)
Form hangs [message #328117] Thu, 19 June 2008 00:05 Go to next message
lakshmisaran
Messages: 26
Registered: May 2008
Junior Member
Hi Friends,

One of my client in India accessing a 10g version form. He copies data from excel and pastes. for 2 or 3 entries it works fine, or max 5 to 10mins. Then the form hangs, he has to close the window and reopen again. Anyone can guess or experienced like this before.
I asked him to enter manually, seems it hangs again.
I've tested it overhere and it works fine. I copied the data from excel shee and also manually entered. Both working fine.

Rgds,
Lakshmi
Re: Form hangs [message #328128 is a reply to message #328117] Thu, 19 June 2008 01:00 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
Quote:
I asked him to enter manually, seems it hangs again.
So actually, what you are saying is that the copy-paste from Excel has nothing to do with the "hang"
How do you expect us to help you with only so little info?
Re: Form hangs [message #329419 is a reply to message #328117] Wed, 25 June 2008 06:55 Go to previous messageGo to next message
lakshmisaran
Messages: 26
Registered: May 2008
Junior Member
Sorry for giving few details... we narrowed the problem. The connection btw client and server disconnects when the user switch btw excel(2003) and the data entry screen. I've attached the error file which copied from java console. Pls. look into this and give the suggestion.

Thx in advance..

DL



  • Attachment: error.txt
    (Size: 3.54KB, Downloaded 311 times)
Re: Form hangs [message #329459 is a reply to message #328117] Wed, 25 June 2008 08:41 Go to previous messageGo to next message
cjack
Messages: 22
Registered: June 2008
Junior Member
Hi,

I guess there are some problem with network, if network is very slow, and the form blocks/records/fields need do much validation from DB or getting much data to front-end, these all will occur the hangs.

Jack
Re: Form hangs [message #329640 is a reply to message #328117] Thu, 26 June 2008 02:25 Go to previous messageGo to next message
lakshmisaran
Messages: 26
Registered: May 2008
Junior Member
Yesterday I accessed the client machine and did so much of simulation and found that user navigates from form to Excel application to see the data. during navigation the form or front end is disconnected from the db server. LOV , clear block and keyboard navigation doesnt work. If he doesnt navigate to excel application the form works fine.

I uninstalled SDK 2 and jinitiator1.3.1.22. Reinstalled jini1.3.1.22 again but same problem persist.

Any suggestions on proceeding next.

FYI, the form load very less data max of 25 records per transaction. Server is in s'pore and client is in India.

Attached the error file again..

Rgds,
DL
  • Attachment: error.txt
    (Size: 3.54KB, Downloaded 147 times)
Re: Form hangs [message #330373 is a reply to message #329640] Sun, 29 June 2008 23:54 Go to previous message
lakshmisaran
Messages: 26
Registered: May 2008
Junior Member
I've contacted the Oracle via Metalink. they've asked me to apply patch. Will update whether the form works fine once the patch applied.

Rgds,
Dl
Previous Topic: How make a block of base view in form?(can't coding in trigger)
Next Topic: when button pressed
Goto Forum:
  


Current Time: Sat Dec 03 18:31:01 CST 2016

Total time taken to generate the page: 0.13330 seconds