Home » SQL & PL/SQL » SQL & PL/SQL » join (oracle 10g sql windows xp)
join [message #327683] Tue, 17 June 2008 04:16 Go to next message
varosh81
Messages: 178
Registered: February 2008
Location: CHENNAI
Senior Member
I have 3 tables table1,table2 and table3. Table1 contains say 100 records and table2 contains 50 records,table2 contains 25 records.. There is one common column in both the table on which I am trying to match in where condition. But the problem is other than the matched data I also need to display the unmatched records in table1 which needs to be substituted by 'No data found' string.
Please hellp me and send the solution as I am new to sql.

[Updated on: Tue, 17 June 2008 04:19]

Report message to a moderator

Re: join [message #327685 is a reply to message #327683] Tue, 17 June 2008 04:18 Go to previous messageGo to next message
ThomasG
Messages: 3189
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
You need an outer join instead of the join you have now.

Post the query you have now, then we can tell you how to adjust it.
Re: join [message #327687 is a reply to message #327685] Tue, 17 June 2008 04:20 Go to previous messageGo to next message
varosh81
Messages: 178
Registered: February 2008
Location: CHENNAI
Senior Member
SELECT *
FROM academic_det_pg
FULL OUTER JOIN academic_det_ug
ON academic_det_pg.applicant_id = academic_det_ug.applicant_id ,
FULL OUTER JOIN academic_det_otherqualif ON
academic_det_otherqualif.applicant_id = academic_det_ug.applicant_id


display error this query is not working
Re: join [message #327689 is a reply to message #327683] Tue, 17 June 2008 04:21 Go to previous messageGo to next message
seyed456
Messages: 220
Registered: May 2008
Location: south india .
Senior Member

hi varosh,


post the result chart ..
Re: join [message #327691 is a reply to message #327687] Tue, 17 June 2008 04:23 Go to previous message
ThomasG
Messages: 3189
Registered: April 2005
Location: Heilbronn, Germany
Senior Member
So you already have an outer join.

What is the error?

Why is it "not working"

There is a syntax error I see, there shouldn't be that comma at the end of line 4.
Previous Topic: Data Conversion
Next Topic: i need a query
Goto Forum:
  


Current Time: Fri Dec 02 19:02:40 CST 2016

Total time taken to generate the page: 0.18460 seconds