Home » Server Options » Data Guard » Problem in setting Archive destination for standby database (10.2.0.1.0)
Problem in setting Archive destination for standby database [message #325884] Mon, 09 June 2008 06:44 Go to next message
ranvijaidba
Messages: 71
Registered: May 2008
Location: Bangalore
Member
i am getting problem when i am trying to set log archive destination for standby database which is in the same system.

The following parameter is set in parameter file:

log_archive_config='dg_config=(primary,phstandby)'
log_archive_dest_1='LOCATION=f:\oracle\primaryarch VALID_FOR=(ALL_LOGFILES,ALL_ROLES) DB_UNIQUE_NAME=primary'
log_archive_dest_2='LOCATION=f:\oracle\standbyarch VALID_FOR=(ONLINE_LOGFILES,PRIMARY_ROLE) DB_UNIQUE_NAME=phstandby'
LOG_ARCHIVE_DEST_STATE_1=ENABLE
LOG_ARCHIVE_DEST_STATE_2=ENABLE
FAL_SERVER=primary
FAL_CLIENT=phstandby
DB_FILE_NAME_CONVERT='f:\oracle\oradata\PRIMARY','f:\oracle\oradata\STANDBY'
LOG_FILE_NAME_CONVERT='f:\oracle\primaryarch,'f:\oracle\standbyarch'
STANDBY_FILE_MANAGEMENT=AUTO


The archive list command shows online single archive location:

SQL> archive log list
Database log mode Archive Mode
Automatic archival Enabled
Archive destination f:\oracle\primaryarch
Oldest online log sequence 27
Next log sequence to archive 29
Current log sequence 29


Output from v$archive_dest_status:
SQL> select dest_id,dest_name,status,error,type,database_mode from v$archive_dest_status;

DEST_ID DEST_NAME STATUS ERROR TYPE DATABASE_MODE
---------- ---------- --------- ---------- -------------- ---------------
1 LOG_ARCHIV VALID LOCAL OPEN
E_DEST_1

2 LOG_ARCHIV BAD PARAM ORA-16053: LOCAL OPEN
E_DEST_2 DB_UNIQUE_
NAME is
not in the
Data Guard
Configurat
ion

Please help me due to this problem i am not able to start standby database.Thanks in advance.


Re: Problem in setting Archive destination for standby database [message #325998 is a reply to message #325884] Mon, 09 June 2008 20:59 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
What did you set the DB_UNIQUE_NAME init parameter to?
Re: Problem in setting Archive destination for standby database [message #326053 is a reply to message #325998] Tue, 10 June 2008 01:22 Go to previous messageGo to next message
ranvijaidba
Messages: 71
Registered: May 2008
Location: Bangalore
Member
Primary database Parameter file contain this setting:
db_domain=net
db_name=primary
db_unique_name=primary
service_names=primary

Phusical Standby parameter file contain this setting:
db_domain=net
db_name=primary
db_unique_name=phstandby
service_names=phstandby

Is DB_UNIQUE_NAME is required in LOG_ARCHIVE_DEST_n parmeter if both priamary and standby are located in same system?

[Updated on: Tue, 10 June 2008 01:48]

Report message to a moderator

Re: Problem in setting Archive destination for standby database [message #326128 is a reply to message #326053] Tue, 10 June 2008 04:59 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
Have you tried to specify a SERVICE_NAME=phstandby instead of LOCATION for log_archive_dest_2 parameter?
Re: Problem in setting Archive destination for standby database [message #326913 is a reply to message #325884] Fri, 13 June 2008 01:23 Go to previous messageGo to next message
ranvijaidba
Messages: 71
Registered: May 2008
Location: Bangalore
Member
I tried SERVICE_NAME but it is showing error ORA-12154

I have some doubt:
1-Is Tnsnames file contain entry for both primary and standby database .if yes then what oracle sid we have to specify in SID parameter.
2-if primary and standby database are located in the same system than SERVICE_NAME is required in LOG_ARCHIVE_DEST_2.
3-Only it is showing error for standby DB_UNIQUE_NAME not for primary database when i am using LOCATION in place of SERVICE.

Re: Problem in setting Archive destination for standby database [message #327025 is a reply to message #326913] Fri, 13 June 2008 08:12 Go to previous messageGo to next message
ebrian
Messages: 2794
Registered: April 2006
Senior Member
You need to have an entry in the tnsnames for phstandby and should be able to connect with SQL*Plus using this alias. Use SERVICE_NAME in tnsnames entry instead of SID. It is showing error for standby DB_UNIQUE_NAME because you should be using SERVICE_NAME for LOG_ARCHIVE_DEST_2 parameter.
Re: Problem in setting Archive destination for standby database [message #327478 is a reply to message #327025] Mon, 16 June 2008 09:19 Go to previous message
ranvijaidba
Messages: 71
Registered: May 2008
Location: Bangalore
Member
Thanks ebrian problem is solved.
Previous Topic: switchover problem
Next Topic: Implement Logical Dataguard
Goto Forum:
  


Current Time: Fri Dec 09 17:31:39 CST 2016

Total time taken to generate the page: 0.32397 seconds