Home » Developer & Programmer » Reports & Discoverer » Page not displaying (reports 10g)
Page not displaying [message #325794] Sun, 08 June 2008 22:59 Go to next message
Messages: 26
Registered: May 2008
Junior Member
Hi all,

these code are in before parameter form
  :P_cname := 'test;
  :P_heading := test For the Period From ';
  :p_pl_date := '01-OCT-02';
  :p_pr_type := 'CC';
  :p_unit_brok := 'U';
  :p_proc_type := 'Reprocess';
  :p_arbpl := 'GBP';
  :p_grp1 := 'a.region';
  :p_grp2 := 'a.sd';
  :p_grp3 := 'a.trd';
  --:desname := nvl(:desname,'f:\Cocoa2003\Accounts\Sys_Summary_PL\FPL.PDF');  
  :desformat := nvl(:desformat,'PDF');
  select distinct sid into :p_sid from v$mystat;
return true;

These coding are in after parameter form:
  :P_heading := :P_heading || to_char(:p_fdate) || ' To ' ||to_char(:p_tdate);
  if upper(:destype) in ('FILE','MAIL') then
     if right(:desname,8) = '\FPL.PDF' then
	:desname := replace(:desname,'FPL.PDF') || 'FPL_From_'||to_char(:P_fdate,'RRRR_MM_DD')||'_To_' ||to_char(:P_tdate,'RRRR_MM_DD')||'.pdf';
	:desformat := nvl(:desformat,'PDF');
     end if;
  end if;
  return (TRUE);

When i run the report from report itself, it works fine, but from menu, nothing is displaying except :p_fdate ' To ' :p_tdate values.

Pls. help where i went wrong. its urgent


[EDITED by LF: added [code] tags]

[Updated on: Sun, 08 June 2008 23:43] by Moderator

Report message to a moderator

Re: Page not displaying [message #325801 is a reply to message #325794] Sun, 08 June 2008 23:51 Go to previous message
Messages: 20847
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
its urgent

Please, understand that this is just a forum; people answer questions only when they have enough free time, good will and knowledge to solve someone's problems. The fact that it is urgent for you means absolutely nothing; there are people who will simply skip "urgent" questions, just because. So, if your job suffers from being unable to solve the problem, contact Oracle Support or hire a consultant.

Furthermore, I'd suggest you to read OraFAQ Forum Guide to get familiar with certain rules valid on this forum. Pay attention to proper code formatting; this time, I've done that for you. It is quite simple - enclose it into [code] tags to preserve formatting. If you are not sure how to do that, there's a Test forum at the end of the OraFAQ Forum list so - feel free to test your skills over there.

As of your question: BEFORE and AFTER PARAMETER FORM triggers are simply not enough; it is a QUERY that is responsible for a return data set. These triggers do certain initializations, but ... how are they used in the WHERE clause? Who can tell, but you?

However, this "smells" wrong:
:p_pl_date := '01-OCT-02';
Parameter name suggests that it is a DATE datatype, but '01-oct-02' is a STRING. The correct way to use dates is using the TO_DATE function with a proper format, such as
:p_pl_date := TO_DATE('01-OCT-02', 'dd-mon-yy');
Previous Topic: How to add the value to different columns?
Next Topic: Reports 6i - Calculation on Pagination
Goto Forum:

Current Time: Wed Oct 26 08:12:49 CDT 2016

Total time taken to generate the page: 0.08166 seconds