Home » SQL & PL/SQL » Client Tools » TOAD error for deletion (Toad for oracle 8.6.10)
TOAD error for deletion [message #324936] Wed, 04 June 2008 09:29 Go to next message
tannad
Messages: 43
Registered: January 2008
Location: mumbai
Member
Hi all ,
I am using the toad for oracle 8.6.1.0 version
everything is fine but suddenly I can not use delete,up down,arrows ,backspace in editor

what happen to toad?
is any solution for this?
Re: TOAD error for deletion [message #324994 is a reply to message #324936] Wed, 04 June 2008 13:27 Go to previous messageGo to next message
Littlefoot
Messages: 20891
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
TOAD has a flu. You should keep it warm, measure its temperature, provide enough liquor and take care.

Just kidding, of course!

Really, what happened to TOAD? How are we supposed to know? What did you do? Did you, by any chance, restart? Restart your computer? It usually helps.
Re: TOAD error for deletion [message #324995 is a reply to message #324994] Wed, 04 June 2008 13:44 Go to previous messageGo to next message
Michel Cadot
Messages: 64103
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Or better, through away TOAD and use SQL*Plus (or SQL Developer).

Regards
Michel
Re: TOAD error for deletion [message #325096 is a reply to message #324936] Thu, 05 June 2008 00:28 Go to previous messageGo to next message
tannad
Messages: 43
Registered: January 2008
Location: mumbai
Member
but what is the error suddenly I cannot use these buttons..
can not go backword.. not delete..
is there any solution?
Re: TOAD error for deletion [message #325101 is a reply to message #325096] Thu, 05 June 2008 00:37 Go to previous messageGo to next message
Littlefoot
Messages: 20891
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
tannad
what happen to toad? is any solution for this?

LF
How are we supposed to know? What did you do?
So, did you turn TOAD off and on? Did you restart your computer? Did you reinstall TOAD?
Re: TOAD error for deletion [message #325104 is a reply to message #324936] Thu, 05 June 2008 00:47 Go to previous messageGo to next message
tannad
Messages: 43
Registered: January 2008
Location: mumbai
Member
but what is the error suddenly I cannot use these buttons..
can not go backword.. not delete..
is there any solution?
Re: TOAD error for deletion [message #325105 is a reply to message #325101] Thu, 05 June 2008 00:48 Go to previous messageGo to next message
tannad
Messages: 43
Registered: January 2008
Location: mumbai
Member
I restart my computer and toad also .. but same
Re: TOAD error for deletion [message #325119 is a reply to message #325105] Thu, 05 June 2008 01:30 Go to previous messageGo to next message
Frank
Messages: 7880
Registered: March 2000
Senior Member
Are you a software developer?
If so, what would you think if a client of yours came to you describing the problem you describe here, in the same vague terms?
There is NO such thing as "I did not change anything and suddenly my program does not work anymore". If it worked before and it does not work now, you changed something. ("You" can be very broad: you, your dba, the guy that installs stuff on your computer, etc)
Re: TOAD error for deletion [message #382710 is a reply to message #324936] Fri, 23 January 2009 13:07 Go to previous messageGo to next message
ahmadsa96
Messages: 2
Registered: January 2009
Location: Toronto, ON
Junior Member
Any luck with this? I'm facing the same issue. It's very frustrating.
Re: TOAD error for deletion [message #382712 is a reply to message #324936] Fri, 23 January 2009 13:13 Go to previous messageGo to next message
BlackSwan
Messages: 25036
Registered: January 2009
Location: SoCal
Senior Member
> It's very frustrating.
Then don't (ab)use TOAD & use SQL*Plus;
which is guarenteed to work.

You need to help us by following the Posting Guidelines as stated below.
http://www.orafaq.com/forum/t/88153/0/
So we can help you & please be consistent & correct in your postings.
Re: TOAD error for deletion [message #382713 is a reply to message #382710] Fri, 23 January 2009 13:26 Go to previous messageGo to next message
Littlefoot
Messages: 20891
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
ahmadsa96 wrote on Fri, 23 January 2009 20:07
Any luck with this? I'm facing the same issue. It's very frustrating.

After similar "SQL Editor freezing" happened to me, now I can tell that (unfortunately) I don't have a solution. I have noticed that it happens when (ab)using <Shift + F9> in order to run a statement, but - am I just too fast, do I press two keys simultaneously (such as <F9 + F10>), I really wouldn't know.

Though, I have a possible workaround: <Ctrl + A> to select all in the current SQL Editor window; close SQL Editor; start another SQL Editor; paste clipboard contents into the newly opened SQL Editor window.
What happens when there are a few tabs in the SQL Editor? Can't tell for sure, sorry.

Anyway, if there's something important in the SQL Editor window, I'd suggest you to save it (and do that frequently).
Re: TOAD error for deletion [message #382736 is a reply to message #382712] Fri, 23 January 2009 16:26 Go to previous messageGo to next message
ahmadsa96
Messages: 2
Registered: January 2009
Location: Toronto, ON
Junior Member
BlackSwan,

what is it that you are refering to???
Re: TOAD error for deletion [message #410946 is a reply to message #324936] Wed, 01 July 2009 03:59 Go to previous messageGo to next message
ranakass
Messages: 2
Registered: July 2009
Location: Lebanon
Junior Member
Dear All,

I know it's probably an old problem. I solved it without re-installing the TOAD 8.6 version.

Just go to View->Options->Editor Options (Near the Ok button)->General Options -> Display Options -> Uncheck 'Show right margin' checkbox

Press OK, then Apply

Hope it works for all of you guys.
Best Regards,

RanaKass
Re: TOAD error for deletion [message #410965 is a reply to message #410946] Wed, 01 July 2009 05:48 Go to previous messageGo to next message
Littlefoot
Messages: 20891
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Are you saying that displaying (or not) the right margin solves the problem with someone not being able to use SQL Editor (because of an unknown cause)?
Re: TOAD error for deletion [message #410966 is a reply to message #410965] Wed, 01 July 2009 05:56 Go to previous messageGo to next message
ranakass
Messages: 2
Registered: July 2009
Location: Lebanon
Junior Member
Yep it seems this is the solution for this wierd TOAD error.
I analyzed the situation, it seems that there is a hidden keyboard keys shortcut that enables the 'Show right margin' checkbox. Now i didnt try this solution for other versions that 8.6 but so far this is what seems to be the solution.
If anyone has another solution, please share it with the group.
Thanks,

RanaKass
Re: TOAD error for deletion [message #410967 is a reply to message #410966] Wed, 01 July 2009 06:01 Go to previous messageGo to next message
Littlefoot
Messages: 20891
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
Well thank you, I'd never come to that conclusion, not in million years.

As this funny "locking", "freezing", whatever name we give it still occurs to me (the last one today), I'll try to uncheck the option you've mentioned. And ... wait to see.

Unfortunately, I never knew what exactly causes the problem so I can't test it.
Re: TOAD error for deletion [message #411410 is a reply to message #410967] Fri, 03 July 2009 07:35 Go to previous messageGo to next message
thatjeffsmith
Messages: 66
Registered: July 2009
Location: Raleigh, NC
Member

This is an old bug, since fixed in newer versions of Toad.

"The backspace, up, and down arrow keys don't work in my TOAD. What's going on?"

We suspect that the file "plsqlkeys.bin" is getting corrupted. Please try the following:

1. Close TOAD.
2. Delete "plsqlkeys.bin" from your \User Files directory.
3. Reopen TOAD and see whether those keys now work.

Re: TOAD error for deletion [message #431318 is a reply to message #410946] Mon, 16 November 2009 14:27 Go to previous message
testair
Messages: 1
Registered: November 2009
Junior Member
Don't know if this is the cause of the issue or not..but it resolved the issue...

Thanks....
Previous Topic: TOAD SQLServer 4.1 -- how to view SQLServer2000 "image" datatype
Next Topic: Generating Header and Footer information in a Report
Goto Forum:
  


Current Time: Sun Dec 04 12:38:50 CST 2016

Total time taken to generate the page: 0.05846 seconds