Home » RDBMS Server » Networking and Gateways » Problem in starting Listener (Oracle 9i Enterprise edition. 9.2.0.7.0, AIX 5.2)
Problem in starting Listener [message #324624] Tue, 03 June 2008 06:41 Go to next message
lalitm_2003
Messages: 86
Registered: May 2005
Location: delhi
Member
Hi,
I am facing the problem while starting the listener on the server having Oracle 9.2.0.7.0 database.

The Listener will not respond while issuing start command on lsnrctl prompt.
The Listener log file shows the error:
TNS-12531: TNS:cannot allocate memory

The server is having 16 GB memory. And this problem continues even i shutdown all the databases on the server.
The listener trace file is attached.

Regards
Lalit
  • Attachment: lsnr.trc.txt
    (Size: 38.55KB, Downloaded 434 times)
Re: Problem in starting Listener [message #324630 is a reply to message #324624] Tue, 03 June 2008 06:48 Go to previous messageGo to next message
Michel Cadot
Messages: 57650
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
TNS-12531: TNS:cannot allocate memory
 *Cause:  Sufficient memory could not be allocated to perform the desired
 activity.
 *Action:  Either free some resource for TNS, or add more memory to the
 machine. For further details, turn on tracing and reexecute the operation.

Regards
Michel
Re: Problem in starting Listener [message #325187 is a reply to message #324624] Thu, 05 June 2008 04:48 Go to previous messageGo to next message
lalitm_2003
Messages: 86
Registered: May 2005
Location: delhi
Member
Hi Michel,
Thanks for the reply.
I have checked the memory on the server. Its more than 200MB free when i try to start the listener.
And more than 1G memory is available when i shutdown all the databases and try the same.


Regards
Lalit
Re: Problem in starting Listener [message #325205 is a reply to message #325187] Thu, 05 June 2008 05:14 Go to previous messageGo to next message
Michel Cadot
Messages: 57650
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Quote:
For further details, turn on tracing and reexecute the operation

Regards
Michel
Re: Problem in starting Listener [message #325356 is a reply to message #324624] Thu, 05 June 2008 23:50 Go to previous messageGo to next message
lalitm_2003
Messages: 86
Registered: May 2005
Location: delhi
Member
Hi Michel,
The problem is resolved. I reexcute the same. And it throw error with the hostname.
The problem was with the /etc/hosts file. The SA places the IP address in place of hostname for the IP-hostname mapping.
Thanks Michel for your great help.

Regards
Lalit
Re: Problem in starting Listener [message #325363 is a reply to message #325356] Fri, 06 June 2008 00:35 Go to previous message
Michel Cadot
Messages: 57650
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
Thanks for the feedback.

Regards
Michel
Previous Topic: How to configure SSL?
Next Topic: descriptor not valid
Goto Forum:
  


Current Time: Thu Apr 24 18:34:43 CDT 2014

Total time taken to generate the page: 0.09497 seconds