Home » SQL & PL/SQL » SQL & PL/SQL » DESC not able to display the column name (Win XP, 10G , 10G developer suit)
DESC not able to display the column name [message #324135] Sat, 31 May 2008 02:01 Go to next message
durgadas.menon
Messages: 365
Registered: December 2007
Location: Nowhere
Senior Member
Hi,

I have installed 10g Enterprise edition.

when I run the following select query
SELECT TABLE_NAME FROM DBA_tABLES
it displays the tables but

DESC SALES
(tablename) does not display column names rather it gives a error

Quote:
object sales does not exist


I thought there was no need to run CATPROC.SQL and CATALOG.SQL files in 10G but even tried running that. The result remains the same.

Any idea why this happening and what is the solution?

- Das
Re: DESC not able to display the column name [message #324139 is a reply to message #324135] Sat, 31 May 2008 02:10 Go to previous messageGo to next message
Dipali Vithalani
Messages: 278
Registered: March 2007
Location: India
Senior Member

The table you are trying to describe may not be owned by the user from which you are giving command..
Do this.

select owner,table_name from dba_tables;]


and then try

desc <owner_name>.<table_name>



Regards.
Re: DESC not able to display the column name [message #324142 is a reply to message #324139] Sat, 31 May 2008 02:23 Go to previous messageGo to next message
durgadas.menon
Messages: 365
Registered: December 2007
Location: Nowhere
Senior Member
It seems that I definitely need some sleep..

Thanks a lot

- Das
Re: DESC not able to display the column name [message #324144 is a reply to message #324142] Sat, 31 May 2008 02:25 Go to previous message
Dipali Vithalani
Messages: 278
Registered: March 2007
Location: India
Senior Member

Then you should have it first... Laughing


Regards...
Previous Topic: trouble in selecting case
Next Topic: missing values !!!
Goto Forum:
  


Current Time: Fri Dec 02 14:05:16 CST 2016

Total time taken to generate the page: 0.14372 seconds