Home » Developer & Programmer » Forms » error while running the form (Win XP, 10G , 10G developer suit)
error while running the form [message #323953] Fri, 30 May 2008 02:37 Go to next message
durgadas.menon
Messages: 365
Registered: December 2007
Location: Nowhere
Senior Member
Hi,

Attached are the two errors I am getting when I am trying to run any sub menu items in my form. Here is the PL/SQL code for one sub menu item SEARCH which is under menu item DISPLAY

declare 
	a varchar(60);
	b varchar(60);
	c varchar2(60);
begin
	
	/*Let the user enter the query*/
	enter_query;
	
	/*get the active form name*/
	b := get_application_property(current_form_name);
	/*get the active block name*/
	a := get_form_property(b, first_block);
	
	loop
		
	/*test if there is an underlying table for that block*/
	 c := get_block_property(a, dml_data_target_name);
	 
	 /*disable the form*/
	 if c is not null then
      
       /*calling procedure which in the library to make the form non updateable*/
	 item_enable_disable(a, property_off);
	 
	 end if;
	 
	 a := get_block_property(a, nextblock);
	 
	 if a is null then
	 	
	 	exit;
	 end if;
	 end loop;
	
	end;


I can see the records being displayed but the following two errors keep on popping up on the screen

Quote:
cannot find block: Invalid ID


and

Quote:
Unable to resolve reference to form suplr_dtls


SUPLR_DTLS is the detail data block to the master SUPLR_MSTR

Is this information enough to know that exact problem?

Can anyone guess what might be the problem?

- Das
Re: error while running the form [message #323954 is a reply to message #323953] Fri, 30 May 2008 02:37 Go to previous messageGo to next message
durgadas.menon
Messages: 365
Registered: December 2007
Location: Nowhere
Senior Member
sorry for the files..
  • Attachment: error_1.gif
    (Size: 74.11KB, Downloaded 92 times)
Re: error while running the form [message #323955 is a reply to message #323954] Fri, 30 May 2008 02:38 Go to previous messageGo to next message
durgadas.menon
Messages: 365
Registered: December 2007
Location: Nowhere
Senior Member
second file..
  • Attachment: error_2.gif
    (Size: 74.79KB, Downloaded 84 times)
Re: error while running the form [message #335341 is a reply to message #323953] Mon, 21 July 2008 21:12 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
Did you solve your problem?

David
Re: error while running the form [message #335430 is a reply to message #335341] Tue, 22 July 2008 03:09 Go to previous messageGo to next message
durgadas.menon
Messages: 365
Registered: December 2007
Location: Nowhere
Senior Member
The last time I tried I could not get it. Let me try once more and get back if I still face the problem

Thanks for checking
Re: error while running the form [message #339218 is a reply to message #335430] Thu, 07 August 2008 01:57 Go to previous messageGo to next message
djmartin
Messages: 10180
Registered: March 2005
Location: Canberra ACT Australia
Senior Member
Account Moderator
When in doubt place 'message(); pause;' pairs between EVERY line of code. This will tell you EXACTLY which statement is giving rise to the error.

David
Re: error while running the form [message #339411 is a reply to message #339218] Thu, 07 August 2008 08:03 Go to previous message
durgadas.menon
Messages: 365
Registered: December 2007
Location: Nowhere
Senior Member
Thanks, I will definitely try this
Previous Topic: Please acknowledge. Message in form without Pause command.
Next Topic: How to display from FND_LOBS
Goto Forum:
  


Current Time: Wed Dec 07 12:55:10 CST 2016

Total time taken to generate the page: 0.05503 seconds